Updating nodebb problem

Solved General Discussion
  • Gamers
    #1

    Following the instructions: https://blog.nodebb.org/nodebb-v1-1-0-release/

    After entering the command: git pull

    git-remote-https: /usr/local/lib/libcurl.so.4: no version information available (required by git-remote-https)
    Updating a196c83..296dc77
    error: Your local changes to the following files would be overwritten by merge:
            public/language/pl/category.json
            public/language/pl/email.json
            public/language/pl/error.json
            public/language/pl/global.json
            public/language/pl/groups.json
            public/language/pl/modules.json
            public/language/pl/notifications.json
            public/language/pl/pages.json
            public/language/pl/topic.json
            public/language/pl/unread.json
            public/language/pl/uploads.json
            public/language/pl/user.json
            public/language/pl/users.json
            public/src/client/topic/postTools.js
    Please, commit your changes or stash them before you can merge.
    Aborting
    

    Please advise me. Thanks!

  • Community Rep
    #2

    It looks like you have made local changes to some of the nodebb files.

    You will need to stash them and re-apply.

    git stash
    git pull
    git stash apply

    There will likely be merge conflicts. If so, it will let you know what files have conflicts, and you will need to edit those files manually.

    If you have not made any changes, or wish to discard the changes, you can instead do:

    git checkout -- -f
    git pull

  • Gamers
    #3

    Thanks 😄


Suggested Topics


  • NodeBB install fail

    General Discussion
    0 Votes
    3 Posts
    226 Views

  • 1 Votes
    2 Posts
    830 Views

  • Host NodeBB free

    Unsolved General Discussion
    0 Votes
    6 Posts
    1881 Views

  • 2 Votes
    9 Posts
    3977 Views

  • 0 Votes
    5 Posts
    2070 Views

| | | |