Setup failed while upgrading

Technical Support
  • Hi,

    I was upgrading NodeBB from 0.9.x to 1.x.x, everything went fine until the setup. It failed, and the forum was left with a 503 error. It worked last time. The logs weren't recorded, I don't know why.

    remote: CLIENT_RESULT: Node.js modules installed.
    remote: Preparing build for deployment
    remote: Deployment id is b9b99a10
    remote: Activating deployment
    remote: CLIENT_MESSAGE: Starting MongoDB...
    remote: CLIENT_RESULT: MongoDB started.
    remote: Stopping NodeBB processes
    remote: Configuring NodeBB 1.0.3 for OpenShift
    remote: Overriding app.js
    remote: Pointing uploads directory to /var/lib/openshift/5733908d2d5271463d0000b9/app-root/data/nodebb/public-uploads
    remote: Pointing logs directory to /var/lib/openshift/5733908d2d5271463d0000b9/app-root/data/nodebb/logs
    remote: Pointing config.json to /var/lib/openshift/5733908d2d5271463d0000b9/app-root/data/nodebb/config.json
    remote: Running setup
    remote: 13/5 13:00 [379440] - info: NodeBB v1.0.3 Copyright (C) 2013-2014 NodeBB Inc.
    remote: 13/5 13:00 [379440] - info: This program comes with ABSOLUTELY NO WARRANTY.
    remote: 13/5 13:00 [379440] - info: This is free software, and you are welcome to redistribute it under certain conditions.
    remote: 13/5 13:00 [379440] - info:
    remote: 13/5 13:00 [379440] - info: NodeBB Setup Triggered via Command Line
    remote: Welcome to NodeBB!
    remote: This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    remote: Press enter to accept the default setting (shown in brackets).
    remote: 13/5 13:00 [379440] - info: Now configuring mongo database:
    remote: Configuration Saved OK
    remote: 13/5 13:00 [379440] - warn: You have no mongo password setup!
    remote: 13/5 13:00 [379440] - info: [database] Checking database indices.
    remote: Populating database with default configs, if not already set...
    remote: Previous theme detected, skipping enabling default theme
    remote: Categories OK. Found 22 categories.
    remote: Administrator found, skipping Admin setup
    remote: Enabling default plugins
    remote: 13/5 13:00 [379440] - info: [install/defaultPlugins] customDefaults undefined
    remote: 13/5 13:00 [379440] - info: [install/enableDefaultPlugins] activating default plugins 0=nodebb-plugin-composer-default, 1=nodebb-plugin-markdown, 2=nodebb-plugin-mentions, 3=nodebb-widget-essentials, 4=nodebb-rewards-essentials, 5=nodebb-plugin-soundpack-default, 6=nodebb-plugin-emoji-extended, 7=nodebb-plugin-emoji-one
    remote: 13/5 13:00 [379440] - warn: NodeBB Setup Aborted.
    remote:  Error: schema-out-of-date
    remote:     at /var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/src/upgrade.js:32:29
    remote:     at /var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/src/database/mongo/hash.js:69:4
    remote:     at handleCallback (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb/lib/utils.js:96:12)
    remote:     at /var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb/lib/collection.js:1357:5
    remote:     at handleCallback (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb/lib/utils.js:96:12)
    remote:     at /var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb/lib/cursor.js:661:5
    remote:     at handleCallback (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb-core/lib/cursor.js:159:5)
    remote:     at nextFunction (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb-core/lib/cursor.js:683:5)
    remote:     at /var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb-core/lib/cursor.js:585:7
    remote:     at queryCallback (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb-core/lib/cursor.js:220:18)
    remote:     at Callbacks.emit (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb-core/lib/topologies/server.js:119:3)
    remote:     at null.messageHandler (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb-core/lib/topologies/server.js:358:23)
    remote:     at Socket.<anonymous> (/var/lib/openshift/5733908d2d5271463d0000b9/app-root/runtime/repo/node_modules/mongodb-core/lib/connection/connection.js:292:22)
    remote:     at Socket.emit (events.js:95:17)
    remote:     at Socket.<anonymous> (_stream_readable.js:765:14)
    remote:     at Socket.emit (events.js:92:17)
    remote: CLIENT_RESULT:
    remote: CLIENT_RESULT: .-============================================-.
    remote: CLIENT_RESULT: .  Setup failed.
    remote: CLIENT_RESULT: .
    remote: CLIENT_RESULT: .  There was a problem completing NodeBB setup.
    remote: CLIENT_RESULT: .
    remote: CLIENT_RESULT: .  Check logfile for more information:
    remote: CLIENT_RESULT: .  logs/openshift-nodebb-setup.log
    remote: CLIENT_RESULT: ^-============================================-^
    remote: CLIENT_RESULT:
    remote: -------------------------
    remote: Git Post-Receive Result: failure
    remote: Activation status: failure
    remote: Activation failed for the following gears:
    remote: 5733908d2d5271463d0000b9 (Error activating gear: CLIENT_ERROR: Failed to execute action hook 'deploy' for 5733908d2d5271463d0000b9 application nodebb
    remote: #<IO:0x00000000d17388>
    remote: #<IO:0x00000000d17310>
    remote: )
    remote: Deployment completed with status: failure
    remote: postreceive failed
    To ssh://[email protected]/~/git/nodebb.git/
       11e9191..e0baa80  master -> master

    Could I possibly degrade back to 0.9.x?

  • Surprisingly, the same thing happened in a fresh installation of NodeBB

  • @Aureney i also get an error message after the setup completes but only because i tried to access it too quickly. after i waited few seconds, i refresh and the page loaded. this was on fresh v1.0.3 install.

  • @charles yes, but my setup fails, it doesn't complete.

  • @Aureney i haven't used openshift for a long time because it's so slow. will give it a try again to see if i run into same problem with fresh install.

  • @Aureney Not sure if it's still the case but according to this it's not compatible with nodebb 1.x.x

Suggested Topics

  • Please suggest good way to setup

    Unsolved Technical Support
    0 Votes
    2 Posts

    according to their documentation nodebb only supports mongodb or redis.

    nodebb is easy enough without docker, just need nodejs and the db, and use the cli ./nodebb start ./nodebb stop etc.

    i use a oneshot systemd service to start it at boot:

    [Unit] nodebb After=mongod.service [Service] User=mppc Group=mppc WorkingDirectory=/srv/mppc/forum/ Type=oneshot ExecStart=/srv/mppc/forum/nodebb start RemainAfterExit=yes ExecStop=/srv/mppc/forum/nodebb stop [Install]
  • 0 Votes
    23 Posts

    @kurulumu-Net hmm. That certainly would indicate that 16.x is supported. I was told by @baris some time ago that this wasn't in fact supported, but that could have changed since our last discussion - or, the documentation is incorrect.

  • 0 Votes
    7 Posts

    @julian I confirm the issue is resolved, many thanks for the quick support ☺️

  • 0 Votes
    4 Posts

    Problem solved. For this topic to be any usefull at all:

    Run into first problem trying to point and click install 2 nodebb instances( test and the actual) on the same server and obviously, both couldn't listen on the same 4567 port.

    Second, did the second install from the old docs on readthedocs instead of the official ones from nodebb.

    Third, forgot to also add php-fpm directives to my Nginx config. And start Mongodb.

  • 0 Votes
    1 Posts

    I've run the v1.0.1 updater against my DEV and it did not see that I have 8 plugins with updates available.

    I ran the ./nodebb upgrade command which should have triggered the update mechanism according to:


    But now with v1.0.1 running I see these updates available: