[Solved] upgrade fails


  • Plugin & Theme Dev

    I've executed the following: git pull ./nodebb upgrade as usual.
    But the last command ends with following output:

    [...]
    warn: [plugins/nodebb-widget-essentials] staticDir is deprecated, define CSS files with new staticDirs instead.
    
    fs.js:649
      binding.readdir(pathModule._makeLong(path), callback);
              ^
    TypeError: path must be a string
        at Object.fs.readdir (fs.js:649:11)
        at Object.Meta.themes.get (/home/ole/workspace/NodeBB/src/meta.js:89:7)
        at /home/ole/workspace/NodeBB/src/webserver.js:321:19
        at /home/ole/workspace/NodeBB/node_modules/async/lib/async.js:511:21
        at /home/ole/workspace/NodeBB/node_modules/async/lib/async.js:227:13
        at /home/ole/workspace/NodeBB/node_modules/async/lib/async.js:111:13
        at Array.forEach (native)
        at _each (/home/ole/workspace/NodeBB/node_modules/async/lib/async.js:32:24)
        at async.each (/home/ole/workspace/NodeBB/node_modules/async/lib/async.js:110:9)
        at _asyncMap (/home/ole/workspace/NodeBB/node_modules/async/lib/async.js:226:9)
    
    NodeBB Dependencies up-to-date!
    

    Any suggestions?


  • Admin

    I've run into that before, I think its from a faulty plugin. If you want you can try

    ./nodebb reset
    

    (which will set your theme to Vanilla and deactivate all your plugins)

    or you can remove one at a time from the plugins:active set in redis-cli


  • Plugin & Theme Dev

    kk worked, thanks 🙂

    Since it's just a board to test NodeBB it's ok to reset anything 🙂


Log in to reply
 

Suggested Topics

| |