My Node BB 502 Getway error



  • here is my config ..
    and i got error 205 getwayerror on my nignx ihope that you help me

    node.js running locally on port 3000

    upstream node {
        server 127.0.0.1:3000;
        keepalive 256; # not necessary
    }
     
     
     the public nginx server instance running on port 80
    server {
        listen 80;
        server_name <mysite.com>; # domain of my site
        access_log /var/log/nginx/<mysite>.access.log;
        error_log /var/log/nginx/<mysite>.error.log;
         
        # supposedly prevents 502 bad gateway error;
        # ultimately not necessary in my case
        large_client_header_buffers 8 32k;
     
        # run the app on the root directory
        location / {
     
            # the following is required for WebSockets
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header Host $http_host;
            proxy_set_header X-NginX-Proxy true;
      
            # supposedly prevents 502 bad gateway error;
            # ultimately not necessary in my case
            proxy_buffers 8 32k;
            proxy_buffer_size 64k;
             
            # the following is required
            proxy_pass http://node;
            proxy_redirect off;
      
            # the following is required as well for WebSockets
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";
     
            tcp_nodelay on; # not necessary
        }
     }
    


  • This post is deleted!


  • Show your config.json contents. That will confirm that you have NodeBB running on port 3000 as you have defined in your webserver config.



  • {
    "url":"http://site.com:3000",
    "base_url": "http://site.com:3000",
    "secret": "secrertKeyyy",
    "database": "mongo",
    "port":"3000",
    "bind_address":"0.0.0.0",
    "mongo": {
    "host": "127.0.0.1",
    "port": "27017",
    "password": "",
    "database": "0"
    },
    "use_port":false
    }

    here is my conifg.json how can i config my nginx :( help me



  • @Hartman2508 Change this:
    "url":"http://site.com:3000",
    to this:
    "url":"http://site.com",

    Get rid of the "base_url" line



  • i will remove 300 on my url and remove bse url



  • @Hartman2508 Did those changes work for you?



  • yes tnx man :) for the help


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.