• @Sp4rkR4t

    The obvious question then is, is Redis installed? I know you said you said that "set up redis to work with the app," but it doesn't seem to be showing that.


  • It does seem that dokku hasn't installed redis, trying to get it set up now. Through the guides I've been following and watching dokku auto-install and configure everything else I thought having the dokku redis plugin would install redis for my container, seems that isn't the case.

  • GNU/Linux Admin

    @sp4rkr4t Do you have the ability to execute redis-cli from your Dokku image? If you can ssh into the server and attempt to use redis-cli with the redis credentials, you can see if there's a problem establishing the connection from there.


  • I tried to put on nodebb Doku here on this a manual (nodebb wiki link).

    8 point is passed
    Instead 9th - you have to install the dokker-redis-plugin

    Eventually I got a working application on Dokku, but do not know how to make the configuration process, but I can not process console to answer the questions of the installer.


  • I rebuilt the dokku image and this time install redis-server via apt myself, then installed the dokku-redis plugin and set it up for my forum container as the plugin says, then I pushed the nodebb code and that all set up but still I cannot connect to redis during setup. This is a real shame that I cannot figure this out as I don't really want to move forward with putting the rest of my stuff in containers until I have this figured out/fixed.

  • GNU/Linux Admin

    Hm.. for Heroku setup, I ended up running node app --setup from my local machine, and then pushing the code including the generated config.json file, to the Heroku server. Perhaps something like that is required?


  • No with dokku you can push the node app --setup command to the container fine, just can't get the setup to talk to the redis server.


  • @Sp4rkR4t

    Is there an error log that you can pull info from so you have a better idea why you can't connect to Redis?

  • GNU/Linux Admin

    Also, where is dokku in relation to your redis server? I'm assuming a containered instance won't understand 127.0.0.1 to be your local PC.


  • @julian It's in a container created by the plugin which also is meant to tie it to the forum container. I think you are right that it can't interpret the address correctly as I just tried a clean install but this time with mongodb and that plugin and had the exact same issue.

Suggested Topics

| |