openshift - errors starting server, error 503 as well



  • Hi,

    I finished all the steps in the guide for nodebb/openshift, at the final step it tells you to start the server, i do that and it appears there's no problem because it says this:

    Starting NodeBB
    "./nodebb stop" to stop the NodeBB server
    "./nodebb log" to view server output
    "./nodebb restart" to restart NodeBB

    But when I go to the URL, it has the "503 Service Unavailable No server is available to handle this request" message

    so then I show the log with ./nodebb log and get this:

    Note: I'm making this post short because the forum software is also saying my post is spam and refusing to post it if I include too much detail.

    Hope someone can help, thank you for reading 🙂



  • Please follow this guide and use a new gear to test it.
    https://github.com/ahwayakchih/openshift-nodebb

    We will update NodeBB Documentation after getting some more user feedback and testing.



  • thanks, i was actually able to install it using your new guide ! thanks a lot.

    however, i actually wanted to install one of the plugins, and so i followed those steps too, and after doing git push origin master it did seemed to be installing it, but it stopped here.

    remote: 29/2 20:15 [462396] - info: Now configuring redis database:
    remote: Configuration Saved OK
    remote: Populating database with default configs, if not already set...
    remote: Previous theme detected, skipping enabling default theme
    remote: Categories OK. Found 4 categories.
    remote: Administrator found, skipping Admin setup
    remote: 29/2 20:15 [462396] - info: Global Moderators group found, skipping creation!

    i tried ./nodebb start and it said this

    $ ./nodebb start
    module.js:341
    throw err;
    ^

    Error: Cannot find module 'colors'
    at Function.Module._resolveFilename (module.js:339:15)
    at Function.Module._load (module.js:290:25)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (C:\nodebb\nodebb:3:14)
    at Module._compile (module.js:413:34)
    at Object.Module._extensions..js (module.js:422:10)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Function.Module.runMain (module.js:447:10)

    so i guess i screwed something up? gah 😞



  • @svetlana Did you try that ./nodebb start locally, or after logging in to OpenShift through SSH? Because there's a c:\ path there in your log, which makes me believe you tried to run it locally.

    Can you write which plugin did you try to add?



  • hello, thank you for asking. i tried to add this

    npm install --save nodebb-plugin-videoplayer

    i believe the start command happened to the remote server, because i dont even have it set up on my pc for it to work.

    i know its not approved for v1.0 but i thought it would possibly work in some way (or should i wait for any plug in to be updated to say 1.0 before trying it?)



  • @svetlana Thanks for the info. I'll test that. I just tested with plugin mentioned in example of the guide and it too just hanged there. I'll check it some more and let you know.

    Yes, you should always wait for plugin to be ready for the version of NodeBB you're using. Unless you want to test and let devs know about the results :). But in that case, be sure to test on installation that is "expendable".



  • Ah okay, well good to know, I thought I was just unlucky. Thanks for looking into it. And I will look into having another server for testing in the future but not sure, I'm having enough trouble keeping one going as it is Haha



  • @svetlana It looks like it is a problem of either v1.0 itself or incompatible plugins. I reverted openshift-nodebb README to 0.9.x. You can try fresh install with 0.9.x, and later, when things cool down a bit and plugins are updated, you can update to 1.0.

    AFAIK you can have up to 3 "servers" on OpenShift for free. And since you already know the drill, it should be easy to make another instance of NodeBB just for testing :).


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.