[nodebb-plugin-emailer-mailgun] installs with an error - directory missing



  • I have attempted to install the emailer-mailgun plugin and end up with an error. When I install from the ACP an ENOENT, open error is displayed, momentarily, referencing a path in the plugin that does not exist. The path error is:

    Error ENOENT, open '/path to my installation/node_modules/nodebb-plugin-emailer-mailgun/node_modules/mailgun-js/node_modules/form-data/node_modules/mime/package.json'

    The form-data directory is not there.

    I am running Nodebb v0.9.3 and the emailer-mailgun plugin is reporting itself as version 1.0.0.

    Has anyone else run into this problem and is there a work around to resolve the problem?

    Thank you.

    Edit: This is a low priority issue. I installed the nodebb-plugin-emailer-local-bobo plugin and was able to configure it to use Mailgun just fine. I am using the SMTP settings as opposed to the API call but that is fine for my usage.


 

| |