Noginx related Facebook authorization issue, someone halp?


  • GNU/Linux Admin

    Don't forget the ending quote on the base_url line 🙂



  • @julian fixed. Still doesnt want to work.


  • GNU/Linux Admin

    What error shows up in your console when you attempt to use the proper base_url?



  • @julian said:

    What error shows up in your console when you attempt to use the proper base_url?

    xxxxx@xxxxxx:~/mynodebb# node app
    info: NodeBB v0.3.1 Copyright (C) 2013 DesignCreatePlay Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    info:

    /root/mynodebb/node_modules/nconf/lib/nconf/stores/file.js:141
    throw new Error("Error parsing your JSON configuration file: [" + self.f
    ^
    Error: Error parsing your JSON configuration file: [/root/mynodebb/config.json].
    at File.loadSync (/root/mynodebb/node_modules/nconf/lib/nconf/stores/file.js:141:13)
    at Provider.add (/root/mynodebb/node_modules/nconf/lib/nconf/provider.js:135:23)
    at Provider.file (/root/mynodebb/node_modules/nconf/lib/nconf/provider.js:61:15)
    at start (/root/mynodebb/app.js:78:8)
    at Object.<anonymous> (/root/mynodebb/app.js:67:2)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)

    and my config.json file is

    {
    "base_url": "http://californiamotorcycleforum.com”,
    "port": "4567",
    "use_port": true,
    "secret": "XXXXXX",
    "bind_address": "0.0.0.0",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "",
    "database": "0"
    },
    "bcrypt_rounds": 12,
    "upload_path": "/public/uploads",
    "relative_path": ""
    }


  • GNU/Linux Admin

    Hm... that closing quote at the end of base_url doesn't look right... try replacing it with a regular quote: "



  • @julian it works fine with he ip address. I changed it, plugged in the url again and I'm back to an Error 502 screen.


  • GNU/Linux Admin

    The error in your console is basically saying that it cannot parse the file as it is not valid JSON. I'd recommend trying to run node app --setup if your editor is introducing errant characters into the config.json file...



  • @julian

    Yeah i just use dreamweaver ftp because it's quicker, for me at least. okay i got the website to run while the base_url is http://californiamotorcycleforum.com.
    The facebook issue remains the same, although the app is no longer pinging the ip address.

    Okay. I just deleted the url and domain from facebook's app. Retyped it in again. Hit save. Now it works. this would be rewarding if i knew why that solved it.


  • GNU/Linux Admin

    Nice 😄

    I'm just glad it's working. I'm guessing your dreamweaver doesn't insert a plain ol' quote? Seems like an odd thing for a code editor to not do, but I'll refrain from making any disparaging remarks against that IDE 😄

    Edit: @kevin, can we possibly feature your forum on our main website?



  • I was editing them in plain document mode. That was my bad. It didn't seem to make a difference. The endquote worked fine when we had the ip in the base url.

    And yeah! of course! I'm glad you like it.


Log in to reply
 

Suggested Topics

| |