error: Auth error: Error: ERR invalid password



  • I am trying to install NodeBB at [http://caffeh.com ](link url) but when I run command
    node app --setup
    I get into error:
    error: Auth error: Error: ERR invalid password
    Of course I did setup my password in /etc/redis.conf
    Thank you in advance for any support !


  • GNU/Linux Admin

    Hi @xpcontact -- how far does the installation get before it throws that error? Do you get a chance to enter your auth password?



  • Somehow I managed to solve that issue...
    Now I again stuck somewhere, I installed most of what is supposed to be there, and I started most of the service what is supposed to be running, but for now I can't figure out which direction to proceed: http://caffeh.com/forum/



  • progress:
    http://caffeh.com:4567/
    I was installing all the time the nodebb in /forum why it is in the root ?
    And why I need to add the port 4567 in order to see? I am running nginx


  • GNU/Linux Admin

    Hey @xpcontact -- by default NodeBB listens on port 4567. If you'd like to access the site on port 80 (that is, without the port number), you'll have to have your web server proxy requests to your NodeBB server listening on port 4567.



  • Hi,
    I tried to follow that tuts, here the output of my cat /etc/nginx/vhosts/caffeh.com

    server {
    error_log /var/log/nginx/vhost-error_log warn;
    listen 37.59.29.104:80;
    listen [::]:80;
    server_name caffeh.com www.caffeh.com;
    access_log /usr/local/apache/domlogs/caffeh.com-bytes_log bytes_log;
    access_log /usr/local/apache/domlogs/caffeh.com combined;
    root /home/caffeh/public_html;
    #location / {
    location ~..(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|html|htm|txt|js|css|exe|zip|tar|r$
    expires 1M;
    try_files $uri @backend;
    }
    location / {
    error_page 405 = @backend;
    add_header X-Cache "HIT from Backend";
    proxy_pass http://37.59.29.104:8081;
    include proxy.inc;
    include microcache.inc;
    }
    location @backend {
    internal;
    proxy_pass http://37.59.29.104:8081;
    include proxy.inc;
    include microcache.inc;
    }
    location ~ .*.(php|jsp|cgi|pl|py)?$ {
    proxy_pass http://37.59.29.104:8081;
    include proxy.inc;
    include microcache.inc;
    }
    location ~ /.ht {
    deny all;
    }
    }

    cat /home/caffeh/public_html/forum/config.json

    {
    "base_url": "http://caffeh.com/",
    "port": "4567",
    "use_port": false,
    "secret": "62914b18-6014-443b-85cc-124f9362417d",
    "bind_address": "localhost",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "hidden psw",
    "database": "0"
    },
    "bcrypt_rounds": 12,
    "upload_path": "/public/uploads",
    "relative_path": ""
    }

    I am willing to have my forum at http://forum.caffeh.com in the root ( www.caffeh.com ) I will install docpad as blog / portal
    so far, it works only with port: http://forum.caffeh.com:4567/


  • GNU/Linux Admin

    If you're going to use a separate subdomain, then just paste the config verbatim into a new file in your sites-available folder called forum.caffeh.com.

    Then enable it (assuming you're using sites-enabled-style configuration: cd ../sites-enabled && ln -s ../sites-available/forum.caffeh.com



  • cat /etc/nginx/vhosts/forum.caffeh.com

    It is already there, could you please check what is the problem?

    server {
              error_log /var/log/nginx/vhost-error_log warn;
              listen 37.59.29.104:80;
              listen [::]:80;
              server_name forum.caffeh.com www.forum.caffeh.com;
              access_log /usr/local/apache/domlogs/forum.caffeh.com-bytes_log bytes_log;
              access_log /usr/local/apache/domlogs/forum.caffeh.com combined;
              root /home/caffeh/public_html/forum;
              #location / {
              location ~*.*\.(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|html|htm|txt|js|css|exe|zip|tar|r$
              expires 1M;
              try_files $uri @backend;
              }
              location / {
              error_page 405 = @backend;
              add_header X-Cache "HIT from Backend";
              proxy_pass http://37.59.29.104:8081;
              include proxy.inc;
              include microcache.inc;
              }
              location @backend {
              internal;
              proxy_pass http://37.59.29.104:8081;
              include proxy.inc;
              include microcache.inc;
              }
              location ~ .*\.(php|jsp|cgi|pl|py)?$ {
              proxy_pass http://37.59.29.104:8081;
              include proxy.inc;
              include microcache.inc;
              }
              location ~ /\.ht {
              deny all;
              }
            }
    

  • GNU/Linux Admin

    @xpcontact I would recommend erasing everything in that file and copying the config shown in the guide exactly as it is written there. There should not be any need for the cache expiry headers, logging, root, etc.

    In fact, it looks like you're not even proxying requests to your NodeBB.

    In your case, copy this EXACTLY as shown:

    server {
        listen 80;
    
        server_name forum.caffeh.com;
    
        location / {
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header Host $http_host;
            proxy_set_header X-NginX-Proxy true;
    
            proxy_pass http://127.0.0.1:4567/;
            proxy_redirect off;
    
            # Socket.IO Support
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";
        }
    }
    


  • I went to /etc/nginx/vhosts/forum.caffeh.com
    I copied and pasted your code as it is, nothing works, am I missing something else?


  • GNU/Linux Admin

    Did you restart nginx? Run nginx -t to check for errors.



  • yes I did.

    root@server [/etc/nginx/vhosts]# nginx -t
    nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
    nginx: configuration file /etc/nginx/nginx.conf test is successful


Log in to reply
 

Suggested Topics

  • 1
  • 6
  • 4
  • 2
  • 2
| |