All SSO plugins return error after upgrading NodeBB to V 0.9 - Help



  • After uptgarding (reinstallation) of nodebb, this plugins return error and don't work at all.
    After app starting, I got this warn message:

    7/11 12:20 [31705] - warn: [meta/dependencies] Bundled plugin nodebb-plugin-dbsearch not found, skipping dependency check.
    17/11 12:21 [31705] - warn: [plugins/nodebb-plugin-sso-github] Hook filter:user.delete is deprecated, please use an alternative
    17/11 12:21 [31705] - warn: [plugins/nodebb-plugin-sso-google] Hook filter:user.delete is deprecated, please use an alternative
    17/11 12:21 [31705] - warn: [plugins/nodebb-plugin-sso-twitter] Hook filter:user.delete is deprecated, please use an alternative
    17/11 12:21 [31705] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset -p PLUGINNAME to disable it.

    nodebb-plugin-imgur
    nodebb-plugin-sso-facebook
    nodebb-plugin-sso-github
    nodebb-plugin-sso-google
    nodebb-plugin-sso-twitter
    nodebb-plugin-composer-redactor
    nodebb-plugin-custom-pages
    nodebb-plugin-desktop-notifications
    nodebb-plugin-rss
    nodebb-plugin-youtube
    17/11 12:21 [31705] - info: [User-Invitations] Initializing User-Invitations...
    17/11 12:21 [31705] - info: [plugins/spam-be-gone] Settings loaded
    17/11 12:21 [31705] - info: [User-Invitations] Synced settings: defaultInvitations=10, restrictRegistration=0, invitedUsers=[], inviteGroup=registered-users
    17/11 12:21 [31705] - warn: [plugin/composer-redactor] Another composer plugin is active! Please disable all other composers.
    17/11 12:21 [31705] - info: NodeBB Ready
    17/11 12:21 [31705] - info: NodeBB is now listening on: 0.0.0.0:4567

    list itemWhen I try to login with Facebook, I got:
    L’URL fournie n’est pas autorisée par la configuration de l’application.: Une ou plusieurs URL fournies ne sont pas autorisées par les paramètres de l’application. Elle(s) doi(ven)t correspondre à l’URL du site ou du Canevas, ou le domaine doit être un sous-domaine de l’un des domaines de l’application.
    With googleplus:
    list item400. That’s an error.
    Error: redirect_uri_mismatch
    list itemWith twitter and github I get the same Error.
    With the ancien version of nodebb, all this sso login worked fine.

    Please can somone help me to resolve this problem ??


  • Admin

    Check url in config. Should match the one set in Facebook, and Google.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.