Anyone using sendgrid or mailgun on 0.8.x



  • I'm running NodeBB 0.8.x with mongo backend on heroku

    Tried with both sendgrid and mailgun plugin by installing them from from npm and configured them after deploying. But none of them register as email plugins( dashboard says email plugin not installed). None of them are able to send test emails either.

    This shows up in the log for both(pasted only mailguns) of the plugins:
    5/10 13:15 [72] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.  * nodebb-plugin-emailer-mailgun


  • Admin

    @AFM-Sayem Try not to install plugins via npm, install them only via the plugins page in the NodeBB

    With npm you are always getting the latest version (unless otherwise specified, and there's no way to know which version to use), but the plugins ACP page calls our package manager and installs the right package for your version of NodeBB.

    That said, if you're on master, install the latest version from npm. Long story. @AFM-Sayem, this does not apply to you.



  • @julian The problem is if I don't use npm then the plugins will be lost in the next deploy, since the server will clean and rebuild.

    I just checked the plugin's commit history and it indeed shows an api change that will make it incompatible with 0.8.x branch(action:send.email has been changed to filter:send.email). So I guess the solution for me would be to stick to up to the commit where the api didn't change.


  • Admin

    @AFM-Sayem That is correct 😄 Hope you got it working!


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.