Persona Mobile Menu Not Opening

Technical Support

Suggested Topics


  • 2 Votes
    4 Posts
    463 Views

    @oplik0 said in Show categories vertically in Persona:

    .categories .category-children {
    display: flex;
    flex-direction: column;
    }

    Both of them worked fine.

    Thank you very much, guys!

  • Mobile Menu Bug

    Technical Support
    0 Votes
    8 Posts
    571 Views

    Solved. I fixed it by changing the theme, rebuild and restart and then change the theme back to original, rebuild and restart.

  • Mobile bug ?

    Solved Technical Support
  • 0 Votes
    9 Posts
    2k Views

    @ThomLSA Are you reverse proxied through nginx? Do you have the capacity to add a DNS record?

    If so, then adding it as a subdomain is pretty easy.

  • 0 Votes
    1 Posts
    809 Views

    As I am a irreparable idiot, in the pursuit of messing with my Lavender/Persona hibrid theme I in some likely unrelated way totally destroyed everything.

    I was messing around with CSS, hit restart, and the server went down, hard. And hasnt come back since. I've tried restarting the server, running nodebb resets for widgets, themes, and plugins, restarting nodebb what must be 50 times.

    The log output I'm getting is:

    Clustering enabled: Spinning up 1 process(es).

    26/7 19:57 [1252] - info: Time: Sun Jul 26 2015 19:57:53 GMT-0400 (EDT)
    26/7 19:57 [1252] - info: Initializing NodeBB v0.7.1
    26/7 19:57 [1252] - error: [meta.dependencies] Could not read: nodebb-plugin-spam-be-gone
    [cluster] Child Process (1252) has exited (code: 0, signal: null)

    and when I try to access the page, I get a:

    This webpage is not available

    ERR_CONNECTION_REFUSED

    I assumed this was a redis issue, so I tried restarting redis to no efffect, I know I disabled the emoji plugin so tried to reinstall it via SSH but it didnt help.

    Any suggestions for getting this back up and running?

    Edit 1: Tried running npm install to see if it could be some update issue, will update with results.
    Edit 2: running npm install appears to have fixed it. Future people with this issue, use NPM install and dont be an idiot like me resetting everything.