Google SSO error

Technical Support
  • I am getting:

    Internal error.
    Oops! Looks like something went wrong!
    failed to fetch user profile

    when trying to login using the Google SSO (which seems like it is missing some love, as it shows with weird yellow background color, and colors in general under /admin).

    Any tips to fix that, or is it a bug?

  • Replying for others. The fix to the issue is here. Basically, you need to enable the Google+ API for this to work.

    Still, the Google SSO plugins needs attention. Colors are wrong, and the navigation menu shows "Register" and "Login" even after login too place successfully[0]. Is this yours, @julian?

    [0] This happens if the user hasn't verified the email address, and verification is required.

  • @Fastidious You can turn on "Skip email verification for people who register using SSO?" in your social authentication options if you'd like to auto-verify google+ logins.
    I know this doesn't fix the issue you're reporting, but it would gloss over it 😉

  • @drew said:

    Skip email verification for people who register using SSO

    Yes, I figured that one and enabled it. It is not present on the Twitter SSO (I know, a different plugin, but I wish they all were consistent--after all, they all come from the same author, no? Haha!)

    I have all three major "social" logins enabled now, Twitter is the only one "limping" as it does not provides an email address, and hence confirmation emails never get to the destination.

  • @Fastidious That's because Twitter SSO is the WOOOOORST. It gives no email address. So you can't link it to an existing user. #fail

Suggested Topics