Strange behavior



  • I don't know for sure what is going on but i have already tried 3 diferent themes and they all behave in a strange way.
    So im in the homepage of the forum if i choose a category the topics display like this:
    1.PNG
    But if i reload the website the page is displayed properly like this:
    2.PNG
    If i go backward or forward the page doesnt disply properly, but if i reload the page it shows good.
    This happens in every theme except the persona theme.



  • To clarify the issue as I've experienced it too:
    If you switch themes on the ACP, restart, and navigate through pages in your browser, then switch theme back, restart, and navigate again you get weird broken pages.
    You can Ctrl + F5 to reload a page, but then if you use your browser's back button you can get the broken page again easily.
    I was Ctrl + F5ing the home page. Clicking a category, clicking 'back' on my mouse and getting a broken homepage.



  • Any way to fix this?


  • Admin

    NodeBB's cache buster is based on its current git hash (so if you've upgraded it will try to send you the new CSS and JS, which works well, but it remains the same if switching themes, which results in your issue)

    I suppose the dev team hasn't run into this because we usually run with cache disabled while testing (and because Persona is so awesome so why switch? Kidding)

    https://github.com/NodeBB/NodeBB/issues/3573


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.