Installing on FreeBSD, error

Technical Support
  • I am getting the following when trying to run nodebb setup:

    5/9 18:51 [77800] - info: NodeBB Setup Triggered via Command Line
    
    Welcome to NodeBB!
    
    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567) 
    Please enter a NodeBB secret (f424bbc1-94e5-43a9-9fc0-0d482d9f445b) 
    Which database to use (redis) 
    
    5/9 18:51 [77800] - info: Now configuring redis database:
    Host IP or address of your Redis instance (127.0.0.1) 
    Host port of your Redis instance (6379) 
    Password of your Redis database 
    Which database to use (0..n) (0) 
    Configuration Saved OK
    [email protected] node_modules/redis
    
    [email protected] node_modules/connect-redis
    ā””ā”€ā”€ [email protected] ([email protected])
    Populating database with default configs, if not already set...
    module.js:355
      Module._extensions[extension](this, filename);
                                   ^
    Error: /usr/local/lib/gcc48/libstdc++.so.6: version GLIBCXX_3.4.21 required by /usr/local/www/node/nodebb/node_modules/lwip/build/Release/lwip_image.node not found
        at Error (native)
        at Module.load (module.js:355:32)
        at Function.Module._load (module.js:310:12)
        at Module.require (module.js:365:17)
        at require (module.js:384:17)
        at /usr/local/www/node/nodebb/node_modules/lwip/lib/Image.js:3:22
        at Object.<anonymous> (/usr/local/www/node/nodebb/node_modules/lwip/lib/Image.js:15:3)
        at Module._compile (module.js:460:26)
        at Object.Module._extensions..js (module.js:478:10)
        at Module.load (module.js:355:32)
    

    Any ideas of what it could be?

  • Got it. Installed gcc5 and that solved the problem.

  • @Fastidious did you follow the official docs? If so, a pull request to add that extra step is greatly appreciated. Just hit the edit button on the top right šŸ™‚

    EDIT: oops, I guess we don't even have a FreeBSD section in our docs. What OS did you use as your guide? Could add a new page copied and pasted from the original and adding your last step.

  • @psychobunny I simply installed node withpkg (did not use ports), cloned NodeBB and did the regular routine (npm install, nodebb setup, etc.). It was crashing on setup because I had gcc48. Installed gcc49, no dice. Finally installed gcc5 and updated libmap.conf under /etc/ as follows:

    libstdc++.so.6  gcc5/libstdc++.so.6
    

    And the beast took a deep breath, and opened its eyes. Hehe.

  • @psychobunny said:

    Could add a new page copied and pasted from the original and adding your last step.

    I can come up with a page. It should be fairly straight forward, but I already had many things installed on that VPS, so I am not sure if whatever requirements were needed I already had them.

  • You seem to know a lot more about this than any of our core team. Myself especially šŸ˜‰

    If you could add a freebsd section to the docs then kudos to you, likely somebody else will run into the problem you had and I'd have no idea how to respond šŸ˜›

  • @psychobunny said:

    If you could add a freebsd section to the docs then kudos to you

    Done. Pull request pending.

  • Thanks! šŸ™‚ the PR is missing a link from the OS page to your new page though

  • Which JS engine do you use, v8? Maybe it's related to that.

    I'm using FreeBSD too (now with mongodb), and I didn't have to install gcc5 or do any /etc changes to use NodeBB with redis.

  • @rfc2822 if you have a newer gcc installed, there is no reason to install or perform the changes I had to do. My server is not "vanilla" FreeBSD, it is "tinkering-a-lot" FreeBSD.

  • You wrote "It was crashing on setup because I had gcc48". I only have gcc-4.8.5 installed, too (I highly prefer Clang, so I'm not picky about having the latest gcc version).

  • @rfc2822 4.8.5 is fine, 4.8 is not. Do this:

    strings /usr/local/lib/gcc48/libstdc++.so.6 |grep GLIBCXX_3.4.21
    

    If you see it, you are fine.

  • Ok,. I have just thought every gcc48 version would crash for you. ā€“ So everything is OK šŸ™‚

    Really love NodeBB & FreeBSD šŸ™‚


Suggested Topics


  • Installing on OpenServer

    Unsolved Technical Support
    0 Votes
    7 Posts
    473 Views

    So what's the problem? What errors are you getting? Share your nginx config and config.json

  • 0 Votes
    1 Posts
    558 Views

    Hi.

    I'm currently using an Ubuntu server and I want to install Wordpress and NodeBB, for example:
    mydomain. com (Wordpress)
    forum.mydomain. com or mydomain. com/forum (NodeBB)

    I tried some things but failed. NodeBB need to be installed with Node.js and Wordpress with Apache or Nginx, but there are some conflincts when I'm using both.

    I've searched and read some topics but none helped me (not my situation or didn't understood them).

    Thanks for your help!

  • 0 Votes
    2 Posts
    819 Views

    Try using digital ocean instead of open shift as we do not provide support for the latter.

  • 0 Votes
    13 Posts
    3k Views

    Old, i know but still relevant.
    One important thing to consider is not to use mongodb. I don't know if Azure has a strange config that doesn't go well with nodebb's standard config or if it's just a bug in their current version (they use 3.2, current is 3.6 on Ubuntu, 4.2 on Windows).
    It works with redis (at least connection from my VM succeeded).
    Also julienstroheker managed to get an older version of nodebb running in an azure App Service. So basically there is a way šŸ™‚

  • Error after update to 0.9.3

    Unsolved Technical Support
    0 Votes
    27 Posts
    9k Views

    I have run again ./nodebb setup , update the system , run in dev mode ...same problem .
    The database is crashing , not loading the topics .

    0_1450788721810_AVlOT8t.png

    I dont know ..is strange , i have update both forums , and nodebb.es , have this problem .... šŸ˜„

    @julian can you please help me with this ? i am stuck .. šŸ˜ž