Installation errors on Openshift for v0.8.x



  • Hello,

    I followed the instructions for Openshift installation given here: https://docs.nodebb.org/en/latest/installing/cloud/openshift.html

    All goes well, until the git push in step 15. The error is as below:

    remote: make: Entering directory `/var/lib/openshift/55e5df787628e1844c000173/app-root/runtime/repo/node_modules/lwip/build'
    remote:   CXX(target) Release/obj.target/lwip_decoder/src/decoder/init.o
    Connection to nodebb-motsai.rhcloud.com closed by remote host.
    fatal: The remote end hung up unexpectedly
    error: error in sideband demultiplexer
    To ssh://55e5df787628e1844c000173@nodebb-motsai.rhcloud.com/~/git/nodebb.git/
       a232439..ff9fe9a  master -> master
    error: failed to push some refs to 'ssh://55e5df787628e1844c000173@nodebb-motsai.rhcloud.com/~/git/nodebb.git/'
    

    If I used version stable instead of v0.8.x in step 14, the installation proceeds well. However, I get a message in the dashboard saying to upgrade to 0.8.x from 0.6.1. The upgrade process fails too.

    Could you help me install v0.8.x on Openshift please?



  • I used master instead of v0.8.x and the installation proceeded. But after completing the setup, again it throws an error:

    ...
    Configuration Saved OK
    redis@0.10.3 node_modules/redis
    
    connect-redis@2.0.0 node_modules/connect-redis
    └── debug@2.2.0 (ms@0.7.1)
    Populating database with default configs, if not already set...
    module.js:338
        throw err;
        ^
    Error: Cannot find module '../build/Release/lwip_image'
        at Function.Module._resolveFilename (module.js:336:15)
        at Function.Module._load (module.js:278:25)
        at Module.require (module.js:365:17)
        at require (module.js:384:17)
        at /var/lib/openshift/55e5df787628e1844c000173/app-root/runtime/repo/node_modules/lwip/lib/Image.js:3:22
        at Object.<anonymous> (/var/lib/openshift/55e5df787628e1844c000173/app-root/runtime/repo/node_modules/lwip/lib/Image.js:15:3)
        at Module._compile (module.js:460:26)
        at Object.Module._extensions..js (module.js:478:10)
        at Module.load (module.js:355:32)
        at Function.Module._load (module.js:310:12)
    

    So it seems to be related to the above build error for lwip decoder.



  • Configuration Saved OK
    redis@0.10.3 node_modules/redis

    connect-redis@2.0.0 node_modules/connect-redis
    └── debug@2.2.0 (ms@0.7.1)
    Populating database with default configs, if not already set...
    module.js:338
    throw err;
    ^
    Error: Cannot find module '../build/Release/lwip_image'
    at Function.Module._resolveFilename (module.js:336:15)
    at Function.Module._load (module.js:278:25)
    at Module.require (module.js:365:17)
    at require (module.js:384:17)
    at /var/lib/openshift/55e86e2189f5cf5581000007/app-root/runtime/repo/node_modules/lwip/lib/Image.js:3:22
    at Object.<anonymous> (/var/lib/openshift/55e86e2189f5cf5581000007/app-root/runtime/repo/node_modules/lwip/lib/Image.js:15:3)
    at Module._compile (module.js:460:26)
    at Object.Module._extensions..js (module.js:478:10)
    at Module.load (module.js:355:32)
    at Function.Module._load (module.js:310:12)

    i have same problem



  • Hi,

    @nhl-pl sent me link to this topic. I've just tested 0.8.x branch: installation and starting up both went smooth and i could login, visit administration panel, etc...

    I followed steps described here: https://github.com/ahwayakchih/openshift-nodebb, just changed 0.7.x to 0.8.x in commands.

    I tested only Redis installation, no plugins yet or anything more specific yet - just visited page, looked around and logged in.

    update: uploading images to topic and as category image works ok too.

    Hope it helps :).


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.