nodebb setup redis database other than 0 ?



  • If i try to setup nodebb with redis and database = 3 get error. If i accept defaults, it's fine ? v0.7.2 nodebb on CentOS + Centmin Mod LEMP web stack

    ./nodebb setup
    1/8 09:54 [5887] - info: NodeBB Setup Triggered via Command Line
    
    Welcome to NodeBB!
    
    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567) 
    Please enter a NodeBB secret (b8f9e5ef-711b-4c94-a9a3-debb7ea40947) 
    Which database to use (redis) 3
    
    1/8 09:54 [5887] - info: Now configuring 3 database:
    1/8 09:54 [5887] - warn: NodeBB Setup Aborted.
     Error: unknown database : 3
        at success (/home/nginx/domains/newdomain.com/public/nodebb/install/databases.js:67:19)
        at /home/nginx/domains/newdomain.com/public/nodebb/install/databases.js:93:4
        at fn (/home/nginx/domains/newdomain.com/public/nodebb/node_modules/async/lib/async.js:638:34)
        at Immediate._onImmediate (/home/nginx/domains/newdomain.com/public/nodebb/node_modules/async/lib/async.js:554:34)
        at processImmediate [as _immediateCallback] (timers.js:367:17)


  • never mind been a while since i installed nodedbb, that prompt was for database = redis not the redis db number which came later on šŸ™‚

    ./nodebb setup
    1/8 09:58 [5915] - info: NodeBB Setup Triggered via Command Line
    
    Welcome to NodeBB!
    
    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567) 
    Please enter a NodeBB secret (09df113d-0255-48b7-8e21-c2d0eba3be54) 
    Which database to use (redis) 
    
    1/8 09:58 [5915] - info: Now configuring redis database:
    Host IP or address of your Redis instance (127.0.0.1) 
    Host port of your Redis instance (6379) 
    Password of your Redis database 
    Which database to use (0..n) (0) 3
    Configuration Saved OK
    redis@0.10.3 node_modules/redis
    
    connect-redis@2.0.0 node_modules/connect-redis
    ā””ā”€ā”€ debug@2.2.0 (ms@0.7.1)
    Populating database with default configs, if not already set...
    Enabling default theme: Persona
    No categories found, populating instance with default categories
    1/8 09:59 [5915] - warn: No administrators have been detected, running initial user setup

Log in to reply
 

Suggested Topics

  • 18
  • 14
  • 7
  • 6
  • 14
| |