Cant setup Nodebb on my Website that uses centos vpn



  • Okay so i have tried a few times to setup nodebb
    Here is the error i get when setting it up with the ./nodebb setup (click this)

    and heres the live results of it My website results



  • var node path = process.env ['NODE_PATH']

    I could be wrong, but to me... this would suggest that NodeJS is not installed or properly configured on your CentOS server. Have you installed all the prerequisites required to run NodeBB? e.g. "yum -y install nodejs git redis ImageMagick npm"

    I will say one thing it sounds like the yum install for nodejs, could be the problem as I had to install mine manually using the NodeJS guide it self. Though if you can do it via NVM, I would suggest that being a better route in the long run, as the yum install version is a older version of nodejs and will give grief later on.

    Hope that helps.

    If your using WHM\cPanel ... check out my guide on how to get it running without the port number.



  • Okay so I tried to configure it now im getting this error Error in my vps terminal and also when i try to install all the prerequisites required for nodebb it says the package is not avaliable?



  • To be honest the answer is there in your screenshot, there is an issue with your connection the Redis database, make sure redis is installed and that you have entered all the correct or default info during the "./nodebb setup" process

    also I noticed that you have nodebb in a nodebb directory, seems a little messy no? also check your config.json file to make sure the details you entered during the setup is correct.



  • @FreshPrince That's NodeBB trying to connect to your redis server on 127.0.0.1:6379 and failing.
    try checking if redis is running:

    redis-cli ping
    

    you should see

    PONG
    

    If not, just start your server with

    redis-server
    

    then check it's running. If it is then you can

    ./nodebb start
    


  • Okay so i decided to use mongodb and do a fresh install on my vps i did everything correctly but getting this error

    heres my stuff {
    "url": "http://centaurilegion.net/",
    "secret": "9e6d1a09-7b06-49ae-a791-7acecd036dd1",
    "database": "mongo",
    "mongo": {
    "host": "127.0.0.1",
    "port": "27017",
    "username": "******",
    "password": "******",
    "database": "nodebb"
    }
    }

    btw i installed nodebb to http://centaurilegion.net/nodebb/ but i put my root directory to http://centaurilegion.net/nodebb/ in my web admin so it should be the same btw i use plesk



  • Yea now mongo cant connect to my databse god 4th day i reinstalled my vps 5 times..


Log in to reply
 

Suggested Topics

| |