Setting up Nodebb fail

General Discussion
  • #1

    Hello, I try to setup nodes when I run ./nodebb setup I got the following error on debian jessie:

    # ./nodebb setup
    7/6 15:57 [3529] - info: NodeBB v0.7.0 Copyright (C) 2013-2014 NodeBB Inc.
    7/6 15:57 [3529] - info: This program comes with ABSOLUTELY NO WARRANTY.
    7/6 15:57 [3529] - info: This is free software, and you are welcome to redistribute it under certain conditions.
    7/6 15:57 [3529] - info: 
    7/6 15:57 [3529] - info: NodeBB Setup Triggered via Command Line
    Welcome to NodeBB!
    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567) 
    Please enter a NodeBB secret (some secret) 
    Which database to use (redis) 
    7/6 15:57 [3529] - info: Now configuring redis database:
    Host IP or address of your Redis instance ( 
    Host port of your Redis instance (6379) 
    Password of your Redis database 
    Which database to use (0..n) (0) 
    Configuration Saved OK
    npm WARN package.json [email protected] license should be a valid SPDX license expression
    [email protected] node_modules/redis
    [email protected] node_modules/connect-redis
    ā””ā”€ā”€ [email protected] ([email protected])
    Populating database with default configs, if not already set...
        throw err;
    Error: Cannot find module './build/Release/magic'
        at Function.Module._resolveFilename (module.js:338:15)
        at Function.Module._load (module.js:280:25)
        at Module.require (module.js:364:17)
        at require (module.js:380:17)
        at Object.<anonymous> (/var/www/html/NodeBB/node_modules/mmmagic/index.js:3:13)
        at Module._compile (module.js:456:26)
        at Object.Module._extensions..js (module.js:474:10)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:312:12)
        at Module.require (module.js:364:17)

    thanks in advance.

  • #2

    You have to install imagemagic separately. According to your OS you can follow the steps that figure in the documentation

    Apt-get install imagemagick should be enought.

  • #3

    I already have it installed:

    dpkg -l *imagemagick*
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name                                                                      Version                                   Architecture                              Description
    ii  imagemagick                                                               8:                               amd64                                     image manipulation programs --     binaries
    un  imagemagick-6.defaultquantum                                              <none>                                    <none>                                    (no description available)
    ii  imagemagick-6.q16                                                         8:                               amd64                                     image manipulation     programs -- quantum depth Q16
    ii  imagemagick-common                                                        8:                               all                                       image manipulation programs -- infrastructure
    un  imagemagick-doc                                                           <none>                                    <none>                                    (no description available)
  • #4

    Noone has any idea why do I get the errors above?

  • #5

    Are you using the proper node build? Doing some quick searching, I've found that people experience this error when they're using a non-default build of node.

  • #6

    I did everything by the book, I tried to compile the node.js from source also to install from repository. I get the same error no matter what. The only thing what is not by the book is the debian version which in my case is jessie.

  • #7

    Does anyone have a solution for my issue?

  • #8

    Latest version of NodeBB doesn't require this dep anymore, so maybe try pulling the latest master?

Suggested Topics

| | | |