update 0.6 to 0.7 failed...


  • GNU/Linux

    I want to update nodebb from 0.6 to 0.7 ,but failed....help.


  • Plugin & Theme Dev

    @song19891121 what's the error?



  • @pichalite here's mine:

    nodebb-theme-vanilla@1.0.130 node_modules/nodebb-theme-vanilla
    5/6 11:55 [7999] - info: NodeBB v0.7.0 Copyright (C) 2013-2014 NodeBB Inc.
    5/6 11:55 [7999] - info: This program comes with ABSOLUTELY NO WARRANTY.
    5/6 11:55 [7999] - info: This is free software, and you are welcome to redistribute it under certain conditions.
    5/6 11:55 [7999] - info: 
    Warning: Redis server does not require a password, but a password was supplied.
    Warning: Redis server does not require a password, but a password was supplied.
    Warning: Redis server does not require a password, but a password was supplied.
    5/6 11:55 [7999] - info: Beginning database schema update
    5/6 11:55 [7999] - error: [upgrade] NodeBB upgrade could not complete, as your database schema is too far out of date.
    5/6 11:55 [7999] - error: [upgrade]   Please ensure that you did not skip any minor version upgrades.
    5/6 11:55 [7999] - error: [upgrade]   (e.g. v0.1.x directly to v0.3.x)
    

    and redis:

    127.0.0.1:6379> GET schemaDate
    "1419033600000"
    


  • > 5/6 11:55 [7999] - error: [upgrade] NodeBB upgrade could not complete, as your database schema is too far out of date.
    > 5/6 11:55 [7999] - error: [upgrade]   Please ensure that you did not skip any minor version upgrades.
    > 5/6 11:55 [7999] - error: [upgrade]   (e.g. v0.1.x directly to v0.3.x)
    

    There's your issue. What version did you upgrade from and to?



  • @a_5mith The current working version which I see in my admin panel is "v0.6.0" and as I was following the wiki, the target version/branch was "v0.7.x". I also tried "v0.6.0" -> "v0.6.x" but failed with a bunch of git/nodejs errors.


Log in to reply
 

Suggested Topics

  • 2
  • 3
  • 8
  • 3
  • 13
| |