API still responds but not anymore the standart web-HTML-interface



  • hello,

    suddenly started having this problem. It came out of nowhere, disappeared again and now is back. Nodebb 0.6. Restarting nodebb does not help eigther. Any suggestions what to do? How come that the API still responds but not anymore the HTML interface? 😞

    please help! 🙂 rewarding with 10k CoinAwesome AWE 😉

    $ cat config.json
    {
    "url": "http://tips.coinawesome.com",
    .......
    "port": ["4567"]
    }
    $ wget 0.0.0.0:4567
    --2015-05-25 03:08:02-- http://0.0.0.0:4567/
    Connecting to 0.0.0.0:4567... connected.
    HTTP request sent, awaiting response... No data received.
    Retrying.

    --2015-05-25 03:08:13-- (try: 2) http://0.0.0.0:4567/
    Connecting to 0.0.0.0:4567... connected.
    HTTP request sent, awaiting response... ^C
    $ wget 0.0.0.0:4567/api/
    --2015-05-25 03:08:20-- http://0.0.0.0:4567/api/
    Connecting to 0.0.0.0:4567... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 116362 (114K) [application/json]
    Saving to: ‘index.html’

    100%[======================================================================================================================================================================================================================================>] 116,362 --.-K/s in 0.001s

    2015-05-25 03:08:20 (168 MB/s) - ‘index.html’ saved [116362/116362]



  • I think I isolated the problem. It must be something with the config inside the database (redis). Because I cloned nodebb again from the repository, copied the config.json file, did npm install and then nodebb setup and the problem appeared again.

    Any ideas? What could possibly be wrong?

    Will now try out if redis has the option to revert like 24h backwards...


  • GNU/Linux Admin

    Hi @v4, I don't understand what the problem is?



  • @julian

    The api responds at http://tips.coinawesome.com/api but not anymore the html interface at http://tips.coinawesome.com/

    It is definitely not a problem of NGINX because it does the same when I do direct local requests via wget to the open port of nodebb.

    Any ideas what to check? Nodebb does not log requests, right?


  • GNU/Linux Admin

    hm, I would try resetting plugins to see if that is the problem.



  • did not help unfortunately:

    $ ./nodebb reset all
    25/5 17:00 [15381] - info: NodeBB v0.6.0-dev Copyright (C) 2013-2014 NodeBB Inc.
    25/5 17:00 [15381] - info: This program comes with ABSOLUTELY NO WARRANTY.
    25/5 17:00 [15381] - info: This is free software, and you are welcome to redistribute it under certain conditions.
    25/5 17:00 [15381] - info:
    25/5 17:00 [15381] - info: [reset] All Widgets moved to Draft Zone
    25/5 17:00 [15381] - info: [reset] Theme reset to Vanilla
    25/5 17:00 [15381] - info: [reset] All Plugins De-activated
    25/5 17:00 [15381] - info: [reset] Settings reset to default
    25/5 17:00 [15381] - info: [reset] Reset complete.

    $ wget localhost:4567
    --2015-05-25 17:01:23-- http://localhost:4567/
    Resolving localhost (localhost)... 127.0.0.1
    Connecting to localhost (localhost)|127.0.0.1|:4567... connected.
    HTTP request sent, awaiting response... No data received.
    Retrying.

    But hey, the admin html interface works now at least!



  • Restarting Redis finally did the job!

    I think.

    Let me check all.



  • Strange enough, it seems that all paths which are longer than just the / seem to work. Even the not-found ones.

    So tips.coinawesome.com/ does NOT work.
    But tips.coinawesome.com/recent or tips.coinawesome.com/x DOES work.

    Super weird. Will upgrade to 0.7 in the next days or even hours. Not exactly easy as I run a modified version of nodebb.

    Any idea how to workarround this bug meanwhile? Would need to let / go to /recent at least. Via Nginx or dns hacks...? What would be easiest?

    On the same server also WeTipCoins.com is running nodebb (same version) which still works without a problem.



  • In case somebody has the same problem:

    location = / {
       return 301 http://tips.coinawesome.com/recent;
    }
    

    inside nginx's config does the trick 😉



  • The home page should be your categories, so you still have an issue, but have masked it via a redirect.

    If someone clicks your logo, your issue will return. Better to set your Home page to recent in the ACP as you're running 0.7.x.



  • @a_5mith said:

    The home page should be your categories, so you still have an issue, but have masked it via a redirect.

    If someone clicks your logo, your issue will return. Better to set your Home page to recent in the ACP as you're running 0.7.x.

    No, in this case there are no categories. Recent or popular/week is good.



  • In that case then, change your home page in the admin pages.


Log in to reply
 

Suggested Topics

| |