Domain configuration-> Digitalocean + Ubuntu with NodeBB installed



  • Hey guys,

    Since there doesn't seem to be 1 document that explains how to set up a domain name to your ubuntu droplet (digital ocean) with nodebb installed I kind of looked around and figured out (might be wrong?) that i need to adjust my nginx & config.json.

    This is what I did but it is not working yet. Any suggestions?

    /nodebb/config.json:

    {
    "url": "http://www.ideocracycommunity.com:4567",
    "secret": "secret code duh....",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "zzzzzzzz",
    "database": "zzzzzzzz nope"
    }
    }

    /etc/nginx/sites-enabled/default:

    server {
    listen 80;

    server_name ideocracycommunity.com;
    
    location / {
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header Host $http_host;
        proxy_set_header X-NginX-Proxy true;
    
        proxy_pass http://127.0.0.1:4567/;
        proxy_redirect off;
    
        # Socket.IO Support
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
    }
    

    }

    DNS SETTINGS DIGITALOCEAN:

    Screen Shot 2015-04-12 at 10.28.47.png



  • @remcokatz said:

    "url": "http://www.ideocracycommunity.com:4567",
    

    Please remove :4567 and start/restart nginx and NodeBB.

    Edit: remove www. helped



  • @nhl.pl Done but now it gives a 502 bad gateway 😕



  • Have you tried to do this?



  • @nhl.pl I just found that yeah.

    Would you be able to copy / paste me the original (standard) nginx file so i can put that one back and then alter it with what that link says?





  • Ok so after having a chat with nhl.pl it seems that the ip for the proxy_pass in the nginx file should be "localhost" instead of "127.0.0.1" because of reasons (digitalocean).

    config.json:

    {
    "url": "http://ideocracycommunity.com:4567",
    "secret": "lolololol",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "lololoo",
    "database": "0"
    }
    }

    nginx:

    server {
    listen 80;
    server_name ideocracycommunity.com;

    location / {
         proxy_pass http://localhost:4567;
         proxy_set_header Upgrade $http_upgrade;
         proxy_set_header Connection 'upgrade';
         proxy_set_header Host $host;
         proxy_cache_bypass $http_upgrade;
    

    }
    }


 

| |

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.