Installing nodebb on openshift



  • and I'm stuck on step 6 of the documentation, and as soon as I try to CD into the nodebb directory. I'm confused about the usage of the commands too, because it looks like after you exit SSH these are local commands, not ones within openshift? Anybody have any guidance?



  • Please try to install NodeBB using this guide.
    https://github.com/ahwayakchih/openshift-nodebb



  • Step 3 is the same line of code that is giving me problems:

     cd nodebb && git remote add upstream -m master https://github.com/NodeBB/NodeBB.git
    

    When I use CD, it CD's on my local machine and not in openshift - is that the intention of this command? The GIT command gets the following error when ran by itself

    fatal: Not a git repository (or any parent up to mount point /home/dopers)
    Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).




  • Not a windows users, using Ubuntu 14.04



  • Please split commands and add 'git init' before or after 'cd nodebb' command.

    git init
    cd nodebb
    git remote add upstream -m master https://github.com/NodeBB/NodeBB.git

    Please read returned errors and configure your Git. Those steps below are optional and it will work without them.

    git config --global user.name "user@server"
    git config --global user.name "username"

    git config --global push.default matching
    git config --global push.default simple



  • Wow man, thanks! That got me all the way to the very last command

    git push origin master
    

    When I do this, the following error is what outputs

    fatal: 'origin' does not appear to be a git repository
    fatal: Could not read from remote repository.
    
    Please make sure you have the correct access rights
    and the repository exists.


  • rhc should do it for you.

    git config branch.master.remote origin
    git config branch.master.merge refs/heads/master

    or maybe

    git push origin master ; git branch --set-upstream master origin/master



  • Using those, the same error occurs but adds the following lines

    The --set-upstream flag is deprecated and will be removed. Consider using --track or --set-upstream-to
    error: the requested upstream branch 'origin/master' does not exist
    

    adding openshift to the command prompts me for a username/pass for the github in NodeBB, if that helps.



  • Looks like a problem on your local machine.

    and

    You can always delete OpenShift Gear and start from a scratch. And creating a new user on your local Ubuntu is not a bad idea in that case.



  • Hi,

    It looks like rhc app create nodebb nodejs-0.10 command did not create nodebb directory.

    Please make sure, that you're running commands on your own computer, not through ssh on OpenShift side.

    Try to remove nodebb from your OpenShift account and start from scratch.

    Calling git init may seemed like it helped, but it created local only repository, which was not connected with any of the others (OpenShift, NodeBB and openshift-nodebb). That is why git push origin master did not work - origin remote was not configured.


 

Suggested Topics

  • 4
  • 3
  • 1
  • 2
  • 2
| |