Problem with websocket connection



  • Hey guys,

    I'm having a struggle here with my nginx/nodebb server here. I have configured my nginx server to proxy all connections to my localhost at port xxxx. The site it's working fine, no issues with connections or persistence, but when i check the browser's console i see this:

    2015-03-24_09-32-00.png

    So far i have not seen anything wrong beside this errors and of course, because of these, the check symbol (connection with server) is always popping on top bar.

    I used nodebb's official docs to configure nginx's proxy. Even with the Socket IO support parameters.

    I also have the latest version of nginx.


  • GNU/Linux Admin

    @limker Please let us know if you're using CloudFlare as a DNS provider (or another provider that doesn't allow WebSockets, possibly?)



  • Yes, in fact I'm using CloudFlare. Is that the problem?


  • GNU/Linux Admin

    Not necessarily, but you'll want to disable CloudFlare services on that subdomain, as CF does not proxy websockets properly.

    Switch over to grey clouds and you should be ok.



  • I switched over to grey clouds in my subdomain, same problem. @julian

    EDIT: correction. It's working. I'll make some test before close this topic. Thanks!


Log in to reply
 

Suggested Topics

| |