invalid operator: $search



  • Hi,.

    Im facing some problems with mongodb and nodebb 😕

    Anyone had the same problem?

      11/3 16:57 [5082] - error: [plugins] filter:search.query,  invalid operator: $search
      11/3 17:01 [5082] - error: [plugins] filter:search.query,  invalid operator: $search 
      11/3 17:01 [5082] - error: /api/search/hgfhf
      MongoError: invalid operator: $search
    at Object.toError (/home/forum/nodebb/node_modules/mongodb/lib/mongodb/utils.js:114:11)
    at /home/forum/nodebb/node_modules/mongodb/lib/mongodb/cursor.js:700:54
    at Cursor.close (/home/forum/nodebb/node_modules/mongodb/lib/mongodb/cursor.js:983:5)
    at commandHandler (/home/forum/nodebb/node_modules/mongodb/lib/mongodb/cursor.js:700:21)
    at /home/forum/nodebb/node_modules/mongodb/lib/mongodb/db.js:1847:9
    at Server.Base._callHandler (/home/forum/nodebb/node_modules/mongodb/lib/mongodb/connection/base.js:445:41)
    at /home/forum/nodebb/node_modules/mongodb/lib/mongodb/connection/server.js:478:18
    at MongoReply.parseBody (/home/forum/nodebb/node_modules/mongodb/lib/mongodb/responses/mongo_reply.js:68:5)
    at null.<anonymous> (/home/forum/nodebb/node_modules/mongodb/lib/mongodb/connection/server.js:436:20)
    at EventEmitter.emit (events.js:95:17)
    

    im using:

    mongod -version
    db version v2.4.13

  • Admin

    NodeBB requires at least mongodb 2.6



  • hmmm.. tried to update again.. got this 😕

    11/3 17:36 [21807] - info: Beginning database schema update
    11/3 17:36 [21807] - error: [upgrade] NodeBB upgrade could not complete, as your database sche              ma is too far out of date.
    11/3 17:36 [21807] - error: [upgrade]   Please ensure that you did not skip any minor version               upgrades.

  • Admin

    Depending on your nodebb version you have to make incremental upgrades. IE you can't upgrade from 0.4.x to 0.6.x you need to go to the latest version on 0.4.x first then to 0.5.x and then to 0.6.x.



  • @baris I'm running lastest v.7 version...


  • Admin

    @Leonardo-Galani What @baris is trying to say is that the code cannot run if the database itself has not been updated.

    You will need to go check out the code from the branch you were on before upgrading, run the upgrade script, go to the next minor version, upgrade, and then go to v0.6.x (or master) and upgrade again.



  • i wasn't sure to do it.. : ) it seems to work.. thanks..


 

| |