Imagemagick libhalfsobit is needed


  • Try to install Imagemagick on CentOs 6.4 64. Getting following error message.

    rpm -Uvh ImageMagick-6.8.7-10.x86_64.rpm
    error: Failed dependencies:
    libHalf.so.4()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libIex.so.4()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libIlmImf.so.4()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libImath.so.4()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libXt.so.6()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libfftw3.so.3()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libgs.so.8()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libjasper.so.1()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    liblcms.so.1()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    liblqr-1.so.0()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libltdl.so.3()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libtiff.so.3()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libwebp.so.4()(64bit) is needed by ImageMagick-6.8.7-10.x86_64
    libwmflite-0.2.so.7()(64bit) is needed by ImageMagick-6.8.7-10.x86_64

    cat /etc/release
    CentOS release 6.4 (Final)
    CentOS release 6.4 (Final)
    CentOS release 6.4 (Final)
    cpe:/o:centos:linux:6:GA


  • @RayZhang01 I solved this by source code install.

  • GNU/Linux Admin

    @RayZhang01 Congratulations!


  • yup. thinking to use it to create our discussion board.


  • you have pretty interesting framework. I am trying it out.

Suggested Topics

| |