My site was there --- and then was gone

  • I was excited after many fumbles and many questions to a coder friend to see my NodeBB forum up and running. I installed it at Digital Ocean.
    However this morning I went to the forum to start getting it going, and it was gone. Said servers could not connect.
    I have submitted tickets - and am told I need to restart the application. All I can find to do that is in the 'Node for Dummies' (which had me totally stumped do to the node->nodejs switch) was
    psychobunny@mynodebb:~/mynodebb$ node app - which isn't working for me.
    I am embarassedly tech challenged - and before someone tells me I have no business trying to set up on a vps if I am challenged in such a way 😉 please know I am trying this as a learning experience.

  • Have you tried running ./nodebb start

  • birchwind@NodeBB:~$ birchwind@NodeBB:~$ ./nodebb start
    birchwind@NodeBB:~$: command not found
    birchwind@NodeBB:~$ -bash: ./nodebb: Is a directory

    Is what I get when I do that - I just realize I think I forgot to install PM2
    (embarassing)update installed PM2 but still getting command not found.

  • Admin

    If you followed my guide, then well, I'm kind of surprised you even made it this far. It's fairly out of date... look at our official documentation instead:

  • @psychobunny - LOL
    yes, going through it I hit LOTS of snags 🙂
    Luckily i had a friend who was taking me through the discrepancies. He reminded me that without PM2 it wouldnt stay running and told me to install it. I forgot and instead was poking about the forum, checking out the various things it could do and was very impressed. then woke up and it was gone.
    When attempting to start nodeBB (now that PM2) is installed, I get this
    I'll go look at the other tutorial.

  • So, I destroyed the droplet and started fresh with the tutorial provided - when it came to the end I ended up:

  • Try running npm install then start nodebb

  • Okay so I went through again and found where I had missed something.
    The forum is up and running. However there were some 'warns' - do I need to do something to correct these?

    (im really sorry everyone 😕 )

  • You can ignore the repository errors it just means in the plugin info they didnt include a repo

  • Great - well all is good. I just have to figure out how to stop it from shutting down when the server goes down - requiring the manual restart. Ill keep looking through the docs - thank you for the help .

  • 😐
    It's down again. It was doing well. It made it through a restart and set itself back up.
    I installed the Forever Service --
    but now its down again. Forever service isnt starting it, ./nodebb start isn't starting it.
    I was just about to work on getting the site onto a domain - and then it was gone
    What is causing it to drop off like that, and what can I do to stop it?

  • @birch go to the console on the Digital Ocean website; Switch to the Directory you have the forum in then type "nodejs app" and then let it run.

  • ive been using putty, does it matter which one I go to?

  • @birch I use the one on the website to start the script just so it stays running.

  • i haven't used it much because I can't right click/paste into it.
    So, I did that, went into the correct directory and did as you said and it still says servers unavailable
    edit it wont recognize the commands if I log in as other than root - not sure if that is the norm.

  • @birch Did you make your created account a Super User? (Put it in the Root Group.) Might want to Restart the Server as well.

  • Yes, Im quite sure the added user was done correctly -

    I'll restart the server.

  • @birch Also, make sure you're in the right Folder when you're trying to start it. Do "CD Folder name" and then nodejs app.

  • alright, so server is restarted. I think I have supervisor installed - did have the Forever Service but removed it.
    went to the directory - entered ./nodebb start - but still not working.

  • @birch Did you put in a redis password during installation ?

Suggested Topics

| |