Plugins Upgraded Beyond Supported Version (Upgraded from 0.5.3 to 0.5.4)



  • Pictures pretty much say it all:
    PluginFailure1.png
    PluginFailure2.png

    Says this when I click upgrade on either one:
    PluginFailure3.png

    Nothing seems to be broken, other than the little red flags here.



  • I go in and update plugins after doing an upgrade. I did so after upgrading to 0.5.3, and maybe 0.5.3 didn't have this protection so it permitted the ACP to install the updated version?



  • This has suddenly gotten much, much worse. It's now telling me there are new versions of most of my plugins. I updated one (nodebb-plugin-dbsearch), and it crashed NodeBB so that I had to do a plugin reset.

    I assume this is due to the 0.6.0 breaking changes, but neither of these behaviors seems appropriate to me. First it was telling me my installed version was too high, now it's telling me to install breaking versions.


  • Admin

    You're still on v0.5.4, yes? NodeBB shouldn't allow you to upgrade the plugins if they're not supported (e.g. upgraded for 0.6.0 compatibility)



  • Shouldn't, but it did (and obviously broke NodeBB by doing it). And yes, still running 0.5.4 and no updates were done between when it was telling me these two very different things. I figured it couldn't be telling me about breaking updates since the code hadn't changed and it was warning me about plugins which were upgraded too high just a few days previously, so I tried one of the upgrades and had to manually reinstall the correct version with npm to get it back to a functional state.



  • @julian This what happened to me. It let me upgrade plugins to ones that did not work.



  • Upgraded to 0.5.5, seems to have the same problem. I haven't verified by actually trying to install the plugins, but unless the 0.6.0 versions work with 0.5.5, it's still broken.

    Plugins.png


  • Admin

    @Shaun You're saying the "latest" version is beyond your current version? Yes, this is intended for the moment.

    The nbbpm serves the same plugins list to all NodeBBs, whatever the version, but v0.5.5 should not let you upgrade past 0.0.15 of dbsearch, for example.

    https://packages.nodebb.org/api/v1/suggest?package=nodebb-plugin-dbsearch&version=0.5.5

    Looks like it should automatically upgrade you to v0.0.16.



  • It's possible that the upgrade it performed when I tried it on 0.5.4 was to 0.0.16. I had to revert to 0.0.15 to get it functioning again. I just assumed 0.0.16 and 0.1.0 both contained the 0.6.x breaking change.

    I will try the upgrade again when I have more time to deal with whatever ehe fallout may be and let you know what I find.



  • I haven't tested but I'm pretty sure, given the experiences of others here, that the actual cause of my NodeBB breakage was dbsearch 0.0.16, so while it's awkward to be told there are all of these upgrades available, I don't think the problem was nbbpm, just a bad plugin.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.