New relic nodejs agent is not compatible with NodeBB forum

General Discussion
  • As mentioned in their website

    I tried adding new relic package into my nodeBB install by adding


    above line to app.js at the beginning. I got the data on my New Relic dashboard and forum was seem to working fine but
    after few days I realized my logout and other plugin routes were not working. here is the console log.

      warn: [hotswap] Could not find router in stack with hotswapId `plugins`

    and also while logout

      warn: [hotswap] Could not find router in stack with hotswapId `auth`

    after removing the new relic agent from app.js its working fine again.

    I just wanted to let other nodeBB forum administrators to know about this issue if they face same problem.

    @ankitpr89 I have looged this issue at there forum. You can alos understand this issue from here.

  • Yeah this is a known issue, the hotswap functionality and newrelic doesn't play nice together.

  • @vatsal Specifically, the "hotswap" plugin (actually, it's built into core, but it should be a plugin) and the newrelic module both modify the application stack using the same method.

    It may be possible to have the hotswap plugin work properly with newrelic, but I haven't the time to check right now 😦

Suggested Topics

  • 0 Votes
    2 Posts

    MongoDB is the recommended data store.

    For development I use redis because it is just easier for me to use (e.g. zrange sortedSet 0 -1 vs db.objects.find({ _key: "sortedSet" }).pretty();)

    All three are supported by the NodeBB team 😄

  • 0 Votes
    4 Posts

    We at NodeBB want to encourage others to take advantage of the fact that it's open source. We offer premium services for brand name corporate clients, and I'll be the first to admit that our pricing may not be at the right point for smaller companies...

    All that said, we know you've created multiple accounts to disguise the fact that you were as recently as a few days ago asking for help setting up NodeBB.

    If you had just used the same account, it would be acceptable: there's no rules against that!

    I'm sorry but it just sounds dishonest and it's within our rights to point it out to would-be purchasers of your service.

  • 0 Votes
    3 Posts

    Alright that is good to know. Thank you 🙂

    Now I just need to figure out why this error seems to show

    Firefox can't establish a connection to the server at wss://

  • Can't set up NodeBB

    General Discussion
    0 Votes
    19 Posts

    @lukelarris I run into the same issue in 14.04 server too. You need to install nodejs-legacy through apt and it's running well then 🙂

  • 0 Votes
    3 Posts

    i have VPS with installed cpanel/Whm...