Can't move, edit, disable, or delete categories.



  • After installing NodeBB, I've run into a strange error. I can edit settings and post topics, but I can't purge or disable any of the default categories. I can create new categories, but after I create the category, I can't purge it or disable it. My settings.json is configured correctly, and everything works besides removing categories.

    I haven't seen anything in the log files about this, the only error I get originates from output.log:

    warn: [plugins/nodebb-widget-essentials] This plugin may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing.
    warn: [plugins/nodebb-widget-essentials] In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset plugin="nodebb-widget-essentials".
    

    I've made sure my installation is up to date, and restarted a few times. Is there anything I can do to fix this?


  • Staff Admin

    Which git revision are you on? Also which database are you using?



  • I'm using Redis 2.8.4

    As for revision, how can I check that? I assume I'm on the most recent release (I used git clone -b v0.5.x when installing) but I'm not sure how to check.
    Edit: on git checkout v0.5.x I get Your branch is up-to-date with 'origin/v0.5.x'.

    Edit 2: I was able to disable one category, and I'm not sure why. I restarted nodebb a few times to see if that would fix my problem, and that happened.

    Edit 3: For whatever reason, I'm now able to disable categories, but unable to purge them or edit their details.


  • Staff Admin

    What happens when you edit and click save? Any errors in the console?
    Also does it happen on master as well?



  • @baris When I click edit (I'm assuming you mean this icon: http://puu.sh/cqsle/37a8d868eb.png), nothing happens. I expect the name "Announcements" would turn into a text box or something, but it doesn't. If I change other settings and click save, the page reloads and I'm greeted with the exact same settings, not the modified ones.

    Here's my log: http://pastebin.com/3NxZHQ7w (I replaced the IP of the redis database and the location of the files with {redacted})

    As for master, I'm not sure how to switch out of the v0.5.x branch. When I run git pull, I get "Already up to date."

    Edit: This may be inconsequential, but just in case... My full stack is currently CloudFlare > Server > Nginx > NodeBB. Node and Redis are running on the same server, and I'm running NodeBB as a user that only has the rights to access the folder NodeBB is installed in and all subfolders.


  • Staff Admin

    Yeah clicking that icon or the category name turns that box into an editable text field. Which browser are you using? Are you able to edit other fields like background color?



  • @baris I'm able to edit them, but when I click save all the values reset. I'm using Waterfox 32, but have also tried in Google Chrome

    Edit: Here's the code for the edit button that doesn't do anything

    <small><i class="fa fa-edit"></i></small>

  • Staff Admin

    Seems to work, can you test on master?

    git checkout master
    git pull
    ./nodebb upgrade
    

    Then start forum and try again clear browser cache as well.



  • @baris

    user@localhost $ git checkout master
    Branch master set up to track remote branch master from origin.
    Switched to a new branch 'master'
    user@localhost $ git pull
    Already up-to-date.
    

    Still ran ./nodebb upgrade, then started the forum, the error persists.



  • Turns out my issues were stemming from CloudFlare not liking socket dot io, so disable CloudFlare if this happens to you!



  • @RalphORama Yeah Cloudflare doesn't support websockets unless you're on one of the two top tiers, pro or business I believe.


Log in to reply
 

Suggested Topics

  • 2
  • 14
  • 2
  • 3
  • 25
| |