[solved] "No data received" when trying to log in

General Discussion
  • update:
    Turns out my redis-server was outdated. Grabbing the newest version from their website fixed it.

    I'm trying to set up nodebb on Debian. I've followed the installation guide for Debian, and everything seems to be mostly working. However, when trying to log in, my browser simply tells me that no data was received. Does anyone have any idea what could be causing this?

  • @mort I'd like to help you out, but need more info...

    Do you get any warnings/errors when running ./nodebb dev ?

    When you get the 'no data received' page can you refresh and get the forum?

    Are you running nginx or some other reverse proxy?

    Please provide as much info as you can. Screenshots, logs, etc.

  • Here's the log from running ./nodebb dev:

    When I refresh the page, I return to the login view, prompting me for a username and password. However, trying to log in again, it gives me this error:

    Failed login attempt, please try again.

    I get the no data received message when accessing nodebb directly on port 4567. When running behind nginx reverse proxy, trying to log in gives me a 502 bad gateway, though the rest of the site seems to work fine. When running behind Apache, trying to log in gives me a "proxy error":

    The proxy server received an invalid response from an upstream server.
    The proxy server could not handle the request POST /login.
    Reason: Error reading from remote server

    I assume nginx and apache are complaining because nodebb isn't working, so that shouldn't be relevant now.

    Looking at the output from ./nodebb dev, it seems like some "pexpire" command is missing from redis. Maybe that was added to a later version than what I have? redis-server --version claims redis is in version 2.4.14, while the website claims 2.8.17 is the latest version. Hang on, I'll try updating...

  • This might be your problem...and solution


  • Ya, an outdated redis was the issue. Updated it, and now everything works nicely 🙂

  • Glad to hear. You might want to check your nginx is up to date as well. Nginx will still work with an older version, but it will act funny...

    Use this to get up to date:

Suggested Topics