Glad to hear. You might want to check your nginx is up to date as well. Nginx will still work with an older version, but it will act funny... Use this to get up to date: nginx: Linux packages