Network issue on 2G Mobile Connections



  • Guys, I am wondering, did we test nodebb on different internet speed?
    For example we are facing a lot of issue when people are using nodebb forum on 2G connected mobile/ tabs.

    No doubt we started using nodebb because it is mobile first. Now having this issue on 2G network connections, make the users unhappy. Maybe we can put in some kind of smooth flow between the page loads/ new post creations, where the page takes time to load.



  • 2G internet is unbelievably slow. what sort of issues? I can imagine that connection to the websocket would drop quite often. Slow to load. However neither of those are the fault of the forum software. But the users connection.



  • I'm on a connection of 10-15ko/s and i never get any issue, this is, yes, slow, but not slow like oter php based forum o_o' ! Much more speedy !


  • Admin

    @ankitpr89 The page should not need to reload every time a post is made or accessed. In fact, less data should be transferred because a full page-load is not required 😄

    It does sound like your users' 2G connections are not being sustained, which may lead to problems. What type of issues are your users seeing?



  • @Technowix @julian I think it need optimization from our send.
    Let me check with @vatsal



  • @julian the most common problem we have heard of is chats not sending immediately when after pressing "send " button and same while posting posts. I also suspect this issue is occurring due to network unstable pings. Otherwise forum is pretty fast, responsive and stable.


  • GNU/Linux

    Not sure about chat but I was able to browse on Airtel 2G on stock NodeBB without issues. I cannot pin point but it could be something related to your customizations. I could be terribly wrong though.


  • Admin

    @vatsal I agree that there is a UI problem with the chat messages and posting on slower internet connections. Pressing send should immediately show your message on the screen, along with a spinner that indicates that the message hasn't been sent yet... followed by a checkmark when it has, and the server acknowledges.


Log in to reply
 

Suggested Topics

| |