ACP parent-category picker not working



  • Hi, I installed the latest code (I guess it is on master branch, not the 0.5.1 release code.when i go to ACP to create category - seems like the parent-category picker not functional well.....



  • @miluo said:

    Hi, I installed the latest code (I guess it is on master branch, not the 0.5.1 release code.when i go to ACP to create category - seems like the parent-category picker not functional well.....

    Could you be a little more specific? "Not functional" and "doesn't work" unfortunately doesn't help us. Have you refreshed your cache after upgrading? Did you run "npm up" after upgrading to make sure everything is up to date? Did you restart/reload Nodebb after upgrading?

    If yes to all of those, please give us more details, screenshots, anything that may help. 👍



  • @a_5mith I did not upgrade, but did a fresh install on my local as follows:

    git clone https://github.com/NodeBB/NodeBB.git nodebb
    sudo npm install
    ./nodebb setup
    ./nodebb start

    when I go to ACP to add parent-category for a category - it did popup a window show a list of categories -- however when i click on of the category (anyone) - not response..

    Now I tried to install the 0.5.1 release code, here is what i did:
    wget https://github.com/NodeBB/NodeBB/archive/v0.5.1.zip
    unzip v0.5.1.zip
    cd NodeBB-0.5.1/
    sudo npm install
    ./nodebb setup
    ./nodebb start

    i cleaned browser cache. also I did "flushall" on redis database before I run nodebb setup.

    i assume i do not need to do git pull the vanilla theme.

    this time when i go to ACP category - it show a blank page, even though the home page show 12 categores.

    Screenshot from 2014-10-05 16:14:47.png



  • @miluo Looks like you've got two nodebb folders now then, one called nodebb, and another called NodeBB-0.5.1.

    The official method for pulling stable is git clone -b v0.5.x https://github.com/NodeBB/NodeBB.git nodebb

    The actual files look fine, I would imagine that when you flushed the database (not a required step), it may have deleted the categories. When you ran nodebb setup a second time, did it ask you to create an admin again?



  • @a_5mith
    (1)yes it did ask me to provide admin name, password. i provided it.
    (2) yes I have 2 folders. but i shutted down the nodebb process from one folder ~/nodebb , and from ~/nodebb-0.5.1 i did: nodebb start.
    (do i need to do: npm up ? I did not do that I assume npm install will take care everything).



  • @miluo For a fresh install, npm install is sufficient. I wasn't sure if you'd upgraded or if it was a new install. 🙂

    I'll mention @julian into this topic as he'll have a better idea on what could have gone wrong with your install.

    You could try running git checkout v0.5.x then git pull in your nodebb-0.5.1 folder. Then restarting nodebb with ./nodebb restart. That would ensure you were actually on a stable branch. Then we can work from there with any other issues you may be encountering.



  • @a_5mith i followed your instruction. now I got another issue - the header missed many things, and login in as admin seems not working....

    Screenshot from 2014-10-05 17:36:38.png



  • @miluo said:

    @a_5mith i followed your instruction. now I got another issue - the header missed many things, and login in as admin seems not working....

    Screenshot from 2014-10-05 17:36:38.png

    Sorry, you also need to run ./nodebb upgrade too.



  • @a_5mith @a_5mith thanks. now nothing works...
    do me a favour -- assuming i am new to NodeBB, and today I want to install fresh and run the stable working version of NodeBB locally. what's the exact steps i should follow? thanks.



  • @miluo said:

    @a_5mith @a_5mith thanks. now nothing works...
    do me a favour -- assuming i am new to NodeBB, and today I want to install fresh and run the stable working version of NodeBB locally. what's the exact steps i should follow? thanks.

    Hmm, odd, assuming you're running Ubuntu, this: https://docs.nodebb.org/en/latest/installing/os/ubuntu.html

    If you're not running Ubuntu, you will find guides for other distros on the left hand side.



  • @a_5mith Thank you for help. yes i am using ubuntu. I followed the exact steps.

    this time everything looks good. i can login as admin, and header looks normal.

    howvere when i go to ACP manage category -- i still got the same problem as before -- it's empty.... it should show those default 12 categories ,,,,,,,,


  • GNU/Linux Admin

    @miluo, there's a small annoying bug that causes the ACP contents to be invisible in certain resolutions -- please resize your window width down about 200px or so...

    Sorry for the inconvenience 😄 I should backport that fix...



  • @julian thanks for the hint- yes i resize it show up. but i still notice some issue - after i click one category from the category picker window, the chose category didn't show in the parent category field. after i refresh the page, it then show up. but not a big issue.

    i have a suggestion --- instead of using a popup menu window for a list of all categories, maybe just use a auto-complete text box to allow user to type in the category name.... this will be much simple when we have many categories (i.e more than 30....).

    Thanks.


Log in to reply
 

Suggested Topics

| |