Can't Install Fresh

Bug Reports
  • I tried to install NBB on my test DO droplet that's in NYC using the instructions provided on the docs page.
    Other than manually having to install git and the other dependencies, I ran into the following issue.

    [email protected]:~$ git clone -b v0.5.x nbb
    Cloning into 'nbb'...
    remote: Counting objects: 50289, done.
    remote: Compressing objects: 100% (75/75), done.
    remote: Total 50289 (delta 26), reused 0 (delta 0)
    Receiving objects: 100% (50289/50289), 16.98 MiB | 3.25 MiB/s, done.
    Resolving deltas: 100% (34907/34907), done.
    Checking connectivity... done.````
    ```[email protected]:~$ cd nbb```

    [email protected]:~/nbb$ ./nodebb setup

    throw err;
    Error: Cannot find module 'nconf'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/tommyboy/nbb/app.js:24:13)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)```

    [email protected]:~/nbb$ node --version

    Any ideas?

  • Isn't it npm install. Then node app - - setup on first? To install dependencies.

  • @esiao the docs say to run sudo apt-get install git nodejs redis-server imagemagick npm

    I had to manually install each of those, then do the git pull, then I tried to run setup which failed. I then reverified that I was running the proper version of nodejs.

  • I've ran npm installs for

    • nconf
    • winston
    • xregexp
    • prompt
    • express-session

    Only to get this message during setup:

    ./nodebb setup
    info: NodeBB v0.5.0 Copyright (C) 2013-2014 NodeBB Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certai
    n conditions.
    info: NodeBB Setup Triggered via Command Line
    info: Welcome to NodeBB!
    info: This looks like a new installation, so you'll have to answer a few questio
    ns about your environment before we can proceed.
    info: Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567)
    Port number of your NodeBB (4567)
    IP or Hostname to bind to (
    Which database to use (redis)
    info: Now configuring redis database:
    Host IP or address of your Redis instance (
    Host port of your Redis instance (6379)
    Password of your Redis database
    Which database to use (0..n) (0)
    info: Configuration Saved OK
    npm http GET
    npm http GET
    npm http 200
    npm http 200
    npm http GET
    npm http GET
    npm http 200
    npm http 200
    npm http GET
    npm http 200
    npm http GET
    npm http 200
    npm http GET
    npm http 200
    [email protected] node_modules/redis
    [email protected] node_modules/connect-redis
    ā””ā”€ā”€ [email protected] ([email protected])
    error: Unable to initialize Redis! Is Redis installed? Error :Cannot find module
    For which I ran
    `npm install reds`
    Then I had to install bcryptjs through npm.
    Basically, the install directions on the Ubuntu page don't appear to be pulling dependencies properly, and installing them.
  • did you try running

    npm install

    without parameters?

  • @EisFrei, I did - thanks for checking though.
    I'm about to nuke this droplet and give it a fresh go. Seems like anytime I hit a wall with NBB and do that, I get a working install next time.

  • After spinning a new droplet, I was able to complete configuration - but am now getting the error of

    error: properties must be inside selector blocks, they cannot be in the root. undefined

    Edit: This appears to be related to Less.

    Lavender and Vanilla are running on their latest 0.0 series builds.

  • Heads up to anyone running redis remotely - Custom CSS is stored around line 49 or so. If something doesn't save properly when you update this CSS, a cat walks across your keyboard, or there's a syntax error, this can (depending on the error) either cause NBB to render no custom CSS, or potentially crash on launch.


    • Run command to change flag responsible for using custom CSS in redis.
    • Fix CSS
    • Realize that you can get a less error when something is being loaded in redis.
  • @Ted said:

    • Run command to change flag responsible for using custom CSS in redis.

    hset config useCustomCSS 0

Suggested Topics