Nodebb buttons don't Work



  • Any buttons like new topic, or reply fail to load, and even running in dev mode I don't see any errors.

    I've tried to reinstall and upgrade but nothings working.



  • What version of NodeBB are you running?
    What OS are you running it on?
    Is this an issue that has occurred on an existing install, or on a new one?



  • It started when I tried to upgrade a 4.2 install to 4.3.

    I have since tried reinstalling several times, and even completely blowing it away and restarting.

    It's running on nginx and ubuntu 14.04



  • @Punkbob, when you were upgrading, did you follow these steps?



  • Yes, explicitly over and over.


  • Admin

    What version is nginx? It may not be new enough (needs to be > 1.3.13)



  • I have the same problem, new install no upgrade.

    nodebb v0.5.0-4
    Using Apache on a CentOS.
    node.js version v0.10.30

    In the admin panel all is working very well.



  • I also have the same issue. New install v0.5.0 although I may have missed a step in the install process.

    NodeBB v0.5.0
    node.js v0.10.32
    Redis 2.8.4 32bit
    Ubuntu 14.04 32bit

    edit - the admin panel is working

    I'm running a digital ocean test droplet. Nginx and Apache are only required for proxy requests, correct?



  • I figured out my problem. I set up forever incorrectly. I think somehow after a server reboot it didn't load NodeBB the way it should. Is this possible? I built maybe 20 instances to figure out what caused my problem.

    Thanks for the hard work on the project!


  • Admin

    @parvan Thanks for checking back in! 🙂



  • Hmmm, it seems to have broke again. It will run for a while without issues and then I will come back in an hour and the buttons don't work. It's strange.


  • Admin

    Check your browser and server console for any errors.



  • I'm checking back in from a while ago. Since the first post I've moved VPS's from digital ocean to ovh and now I'm moved to vpsdime. I highly recommend them. They say the large storage vps IO is too slow for production but so far it has seriously been 10x faster in disk benchmarks and 20% faster in cpu calculations.

    Anyway, back to what I was going to say.

    I started nodebb using a root cron
    @reboot forever start /home/blue/nodebb/app.js
    turns out this gave me the button errors.
    This method works without issues
    @reboot cd /home/blue/nodebb && forever start app.js

    Interesting huh? Hopefully this helps someone avoid the headaches I've encountered. Any ideas why this may be?


 

| |