DigitalOcean + ServerPilot Issue



  • I have a digital ocean vps droplet that I have already existing that is managed by ServerPilot. I have NodeBB setup and running but I cant access it no mater what I try. I created an app on serverpilot for NodeBB like I would for a php site and have uploaded the files in the public directory for it. When I access via the subdomain I get a error message "Forbidden". I tried using the port number to access it but I fail to reach the server but when I open the logs via ./nodebb log it shows that its running fine. Is this caused by the Nginx + Apache combo that ServerPilot has? I would prefer not to have to create a second droplet and pay an additional $5/month for a small private forum for 10 - 20 people. Any help would be appreciated.



  • @Chris-Rabuse Do you have access to Digital Oceans Control Panel? I'm assuming ServerPilot is just a GUI control panel that runs on top of Digital Ocean?

    If that's the case, you can either try installing from Digital Oceans Terminal Window (Docs are available here) and making sure whatever program routes your access (apache or nginx) is configured correctly to forward port 80 of subdomain.domain.tld to ipaddress:4567 of your NodeBB install.

    Reverse Proxy instructions are also in the docs I linked above. Sorry I can't be much more help, I've never used ServerPilot.

    Sidenote: It's usually not advised to put nodebb files into publicly accessible folders. It's not necessary and could* pose a security risk.

    *I don't know what that risk is, and as far as I'm aware it's never happened.



  • @a_5mith Thanks for replying. I have access to it. ServerPilot is an external control panel that installs essentials such as Nginx, Apache, PHP etc... on the server. I did install via CLI over SSH. I will make sure to make the NodeBB files not accessible next time I mess with it.



  • @Chris-Rabuse Sounds good, shout out if you need any more help. 👍



  • I figured it out. When I was having nginx proxy the request to the subdomain I was modifying the existing conf file for that app which has to be renamed from appname.conf to appname.custom.conf otherwise serverpilot will overwrite the file. There was a line referencing another file in appname.d folder which was sending all requests to apache which was breaking it. I now have it up and running.


  • Plugin & Theme Dev

    @Chris-Rabuse I had a lot of trouble on a box that had plesk/cpanel as well for the same reason, it kept overwriting the changes that I had made. Glad to hear that you got it working!



  • @a_5mith I have a new issue now but it could be because I am running the rc version but I installed the latest version available (v0.5.0-2) but I am getting huge CPU spikes randomly from the forum that makes the server sluggish for up to 5 minutes.


Log in to reply
 

Suggested Topics

  • 24
  • 10
  • 15
  • 4
  • 25
| |