Woke up this morning to NodeBB not running.

General Discussion
  • #1

    Afternoon, so, I woke up this morning, to see that my forum had gone down overnight. I rebooted it using Terminal for iPad, and it went down again about 45 minutes later. I'm currently running it in Dev mode to see if I can catch any errors, but I've no idea what caused it.

    The RAM usage does sit quite high when nodebb is running. Around the 79% mark, if I update nodebb while it's running, the server maxes out and crashes. So my question, should I up my RAM, or turn on swap? Or both? Having a full gb of ram should help, amirite? 😆

    The events in ACP stop at 5:30, so I assume that's when it went down, used memory says 70.82M, which doesn't seem that high...

  • NodeBB
    #2

    You should turn on swap before spending more money on ram 🙂 Redis does use more memory when it is writing to disk so that might be why you are seeing those spikes and crashes.

  • #3

    @baris Have set up swap by following this guide. Thanks. 👍

  • #4

    So is it known yet if this was due to an error, or due to legit memory usage?

    Enquiring minds want to know ❓

  • #5

    @zenkamal I have no idea, the last 3 events were editing posts, I had app running in dev mode for an hour, no issues, I then started it normally and left terminal open on the logs while I went out, came back, no issues. I'll keep an eye on it, but since enabling swap, hopefully I won't have any more issues. 😄


Suggested Topics


| | | |