Just screwed my NodeBB installation


  • Hi there.

    I'm very new to NodeBB. Just installed two days ago.

    Wanted to have the bleeding edge NodeBB to try Blue Posts plugin and I screwed it up 🙂

    What I did?

    I pulled the repository as this.

    git pull
    

    on my NodeBB root directory.

    I guess that wasn't the right procedure to update. Now I get this when trying to start NodeBB:

    ./nodebb dev
    
    [after some other OK messages]
    
     module.js:340
        throw err;
        ^
    Error: Cannot find module 'templates.js'
        at Function.Module._resolveFilename (module.js:338:15)
        at Function.Module._load (module.js:280:25)
        at Module.require (module.js:364:17)
        at require (module.js:380:17)
        at Object.<anonymous> (/home/mauricio/nodebb/src/emailer.js:7:14)
        at Module._compile (module.js:456:26)
        at Object.Module._extensions..js (module.js:474:10)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:312:12)
        at Module.require (module.js:364:17)
    
    [loader] Experienced three start attempts in 10 seconds, most likely an error on startup. Halting.
    

    Please, can anybody point me to the right procedure to update to bleeding edge from repo the next time?

    And if is not too much to ask: How could I fix this besides reinstalling NodeBB again?

    Thanks!

  • Admin NodeBB

    I think @psychobunny recently added the templates.js module into package.json. So you will have to run npm install in the nodebb directory. Then try starting again.


  • @baris It worked!

    npm install
    
    [other stuff]
    templates.js@0.0.6 node_modules/templates.js
    

    Thanks very much! 🙂

  • Admin NodeBB

    No problem 🙂


  • Just saw I should started here: Upgrading NodeBB

    Leave it for future newbies.

Suggested Topics

  • 7
  • 2
  • 26
  • 7
  • 5
| |