My Problem



  • Hey guys have been trying to figure out what my problem is but havent been able to fix it.

    I have followed the doc with installing nodebb with installing the apache patch and all but everytime I run it I get a 500 error and / or running with port just gives me chrome cannot connect.

    My setup is using ISPConfig3, Debian7

    nodebb log shows no errors:

    info: [meta/css] Minifying LESS/CSS
    info: [sounds] Sounds OK
    info: [themes] Compiling templates
    info: [themes] Successfully compiled templates.
    info: NodeBB attempting to listen on: 127.0.0.1:4567
    info: NodeBB is now listening on: 127.0.0.1:4567
    info: [meta/css] Done.
    info: [meta/js] Compilation complete
    info: NodeBB Ready
    

    I have added this to my vhost all within </VirtualHost>:

    ProxyRequests off
    
    <Proxy *>
        Order deny,allow
        Allow from all
    </Proxy>
    ProxyPass /socket.io/1/websocket ws://127.0.0.1:4567/socket.io/1/websocket
    ProxyPassReverse /socket.io/1/websocket ws://127.0.0.1:4567/socket.io/1/websocket
    
    ProxyPass /socket.io/ http://127.0.0.1:4567/socket.io/
    ProxyPassReverse /socket.io/ http://127.0.0.1:4567/socket.io/
    
    ProxyPass / http://127.0.0.1:4567/
    ProxyPassReverse / http://127.0.0.1:4567/
    

    One thing I did notice while following the doc that:
    sudo a2enmod proxy_html

    that does not exist for me even after wstunnel patch. Would that be my issue?


  • Admin

    @techabyte Can you access the forum directly (using the IP and port number)?



  • No I cannot it gives me same error that chome could not connect :(


  • Admin

    Can you change the bind_address in your config.json to 0.0.0.0?



  • That now works thanks!, I updated and changed vhost 127.... to 0.0.0.0 tho I am still getting 500 error when trying to access the webpage without the port..


  • Admin

    @techabyte Not sure where to go with that one, as I've never tried setting up a NodeBB with apache proxy before... perhaps @planner can help?



  • Okay, I seem to have solved it I was looking back at the insall docs the section:

    Enable the necessary modules
    sudo a2enmod proxy
    sudo a2enmod proxy_html
    sudo a2enmod proxy_wstunnel
    

    Since I didnt have proxy_html (module doesnt exist) I did some searching on apache vhost proxy issues and saw a guide for something else that mentioned:

    sude a2enmod proxy_http
    

    enabled that restart apache now working I can access it via URL only :D

    haha just a quick one I enabled emailer (local) for SMTP but once I click on the plugin to change settings it loads /admin/plugin/emailer-smtp but then changes to a 404. Is it bugged? (You are running NodeBB v0.4.3.) Everything else seems to be working :)


  • Admin

    Oh, that's a little weird, perhaps it's a typo, and should read "proxy_http" instead of "proxy_html"?

    As for the local emailer, perhaps you can install @psychobunny's fork?

    npm install git+https://github.com/psychobunny/nodebb-plugin-emailer-local


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.