Turkish URL Transliteration

Unsolved Technical Support

Suggested Topics

  • 0 Votes
    5 Posts

    @baris strangely enough, the category list loads now! And it doesn't look like there's any circularness in the list.


    Still, trying to manage the admin group via /admin/manage/groups/administrators or /admin/manage/admins-mods results in a gateway timeout. I've also enabled verbose logging, which displays this upon visiting either of these two urls:

    x.x.x.x - - [01/Nov/2022:17:12:10 +0000] "GET /forum/admin/manage/admins-mods HTTP/1.1" - - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:106.0) Gecko/20100101 Firefox/106.0"

    Now there's no response code. Strange.

  • 0 Votes
    7 Posts

    @retipster The function of these trailing /1 /2 urls is to function as a rough "post index". I think we've all been there when you find a neat bit of content, refresh the page, and then it's gone for good. This problem is exacerbated by sites that change the order of content often (e.g. reddit, facebook) because a tab open for say, 24 hours, once refreshed, would have completely different content.

    The trailing bits point us to an approximate location on the page, if not the direct post itself, so when you refresh, you end up back where you were before, and not at the top.

    Where are you seeing these extra entries? GA?

  • 2 Votes
    20 Posts

    @julian I found this: https://github.com/NodeBB/NodeBB/issues/4734
    Using the certbot configuration, I edited /etc/nginx/sites-available/default

    Leaving the certbot managed parts as they are, my custom config looks like this now:

    proxy_set_header X-Forwarded-Proto $scheme; location / { proxy_pass; }

    The special part is the x-forwarded-proto line, that's what I was needing all along.

    And in /home/nodebb/nodebb/config.json I'm setting the URL with https:

    { "url": "https://forums.mydomain.com", "secret": "<REDACTED>", "database": "mongo", "port": "4567", "mongo": { "host": "", "port": "27017", "username": "nodebb", "password": "<REDACTED>", "database": "nodebb", "uri": "" } }

    This resolved my problem.

  • 0 Votes
    6 Posts

    That is correct. The port if not defined at all is assumed to be 4567, and should only be in the url if the port is required to access the site.

  • Remove accents from URL

    Technical Support
    0 Votes
    2 Posts

    is this a solution?

    GitHub - andrewrk/node-diacritics: remove diacritics from strings ("ascii folding") - Node.js module

    remove diacritics from strings ("ascii folding") - Node.js module - GitHub - andrewrk/node-diacritics: remove diacritics from strings ("ascii folding") - Node.js module


    GitHub (github.com)