Some plugins are not supported after updating the nodebb version to latest


  • Hello @julian

    Recently we updated the nodebb version to v1.18.6 and after updating some plugins are not support and throwing error at build time.

    For example

    Previously we have nodebb version v1.16.0 and which support nodebb-plugin-mentions (version 3.0.2) and after updating nodebb to v1.18.6 and nodebb-plugin-mentions: 3.0.2 won't support and throws error at build time. There we have to update the plugin version.

    We tried below steps also:

    Step1: Update the nodebb version to v1.18.6
    Step2: Run the ./nodebb setup
    Step3: Run the ./nodebb build
    Step4: verified the plugins versions in admin pannel.Ex: mentions plugin => 3.0.2 (Which is not suitable for v1.18.6)
    Step5: Run the ./nodebb upgrade
    Step6: Run the ./nodebb build again.
    Step7: Did restart and rebuild of nodebb.
    Step8: verified the plugin version but the version is same as previous (3.0.2). But it has to update 3.0.4
    

    Which is not helping. Can you please tell me.
    How to update the nodebb plugins without using nodebb admin panel?

    We followed this document: Nodebb Doc

    CC: @vinu

  • GNU/Linux Admin

    @venkat123 You need to run ./nodebb upgrade to update the dependencies. If running that didn't change the mentions version, then something went wrong with the command, or perhaps the mentions plugin is a symlink (and thus does not get updated).


Suggested Topics

  • 6
  • 1
  • 13
  • 2
  • 6
| | |

© 2014 – 2022 NodeBB, Inc. — Made in Canada.