Upgrading to 0.4.3 broke my forum

Bug Reports
  • sudo apt-get install -y python-software-properties
    sudo add-apt-repository -y ppa:rwky/redis
    sudo apt-get update
    sudo apt-get install -y redis-server

  • haha woops. yeah that dummies guide really needs to be updated 😕 thanks @a_5mith 🙂

  • @a_5mith

    Thanks man! Redis is updated, but now the forum is wiped and I can't log in to ACP. Is there something else I needed to do?

  • Forum wiped? That really doesn't seem right... what files do you see in /var/lib/redis? What are their sizes (use ls -lh to check)?

  • @zenkamal updating redis definitely shouldn't wipe anything, do you have a redis password set in your config? I'm not sure if updating redis resets redis.conf and wipes your redis password or not...

  • @a_5mith

    Nope, didn't set up a redis password.

    The only thing I did is type in those four lines, check the version (successfully updated!) and then blammo the forum's gone now. I suppose I could revert to a backup or start all over, but I'd rather try to avoid that 🙂

  • @julian

    These are the files:

    drwxr-xr-x 2 root  root  4.0K May 26 01:24 6379
    -rw-rw---- 1 redis redis 1.1M May 26 14:26 dump.rdb
    drwxrwxr-x 6 root  root  4.0K Apr 22 04:14 redis-2.8.9
    -rw-r--r-- 1 root  root  1.1M Apr 22 04:15 redis-2.8.9.tar.gz
    -rw-rw---- 1 redis redis 131K May 26 15:44 redis.rdb
    

    The forum doesn't have anything on it after the redis update, and my admin login doesn't work. I haven't done anything except follow the digitalocean install guide, set up reverse proxy in nginx.conf, and update redis.

  • I think I know what happened...

    old redis (< 2.4..?) had default database file as dump.rdb. Newer redis configs have the database file set to redis.rdb.

    You should have a config file for redis at /etc/redis/redis.conf. Look for a line that starts with dbfilename. What is its value? It's probably redis.rdb. Change it to dump.rdb and save. Then restart redis: service redis-server restart

  • @julian

    It was already dump.rdb so I left it that way. Restarted redis and still no forum.

    Could the directory structure be at fault? I didn't have the new redis at the location you pointed to, it was at /var/lib/redis/redis-2.8.9. (both redis.conf files point at dump.rdb by the way).

    EDIT: It's back now! You da' man. I'm still not sure which is the real redis.conf file though.


Suggested Topics