Strange thing in navigation urls

General Discussion
  • For any reason I don't know, today each link in navigation icons are prefixed with:


    So, /unread become /unread, /admin, /recent, and so on.

    Nothing inusual in logs, only a few errors with Twitter SSO errors and lot of "Missing translation xxxxxx".

    Any light about this?

  • What does the ACP page for navigation show?

  • An error when I click on these links, of course, and then access writing the correct url /admin.

    In Navigation settings in ACP, each of these links shows are prefixed with / instead of / so I fixed that and all runs ok now. But strange because I am the only one administrator.

  • I am seeing the same thing in our forum. It all started with installing the awards plugin (which never worked) and it all went downhill from there. Even removing the plugin does not seem to help. @Normando did you get to the bottom of this and how did you fix it?

  • I found the issue. In the database the routes are all "corrupt". Not sure what will cause the route to become this way.

    rs0:PRIMARY> x.find( { _key: 'navigation:enabled' })
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac44"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-user\",\"route\":\"/users\",\"class\":\"\",\"id\":\"\",\"text\":\"[[global:header.users]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.users]]\",\"enabled\":\"true\",\"properties\":{},\"order\":\"5\",\"groups\":[]}", "score" : 5 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac40"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-tags\",\"route\":\"/tags\",\"class\":\"\",\"id\":\"\",\"text\":\"[[global:header.tags]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.tags]]\",\"enabled\":\"true\",\"properties\":{},\"order\":\"3\",\"groups\":[]}", "score" : 3 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac49"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-search\",\"route\":\"/search\",\"class\":\"\",\"id\":\"\",\"text\":\"[[]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[]]\",\"enabled\":\"\",\"properties\":{},\"order\":\"8\",\"groups\":[]}", "score" : 8 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac3b"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-list\",\"route\":\"/categories\",\"class\":\"\",\"id\":\"\",\"text\":\"[[global:header.categories]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.categories]]\",\"enabled\":\"true\",\"properties\":{},\"order\":\"0\",\"groups\":[]}", "score" : 0 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac3d"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-inbox\",\"route\":\"/unread\",\"class\":\"\",\"id\":\"unread-count\",\"text\":\"[[global:header.unread]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.unread]]\",\"groups\":[\"registered-users\"],\"enabled\":\"true\",\"properties\":{},\"order\":\"1\"}", "score" : 1 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac45"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-group\",\"route\":\"/groups\",\"class\":\"\",\"id\":\"\",\"text\":\"[[global:header.groups]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.groups]]\",\"enabled\":\"true\",\"properties\":{},\"order\":\"6\",\"groups\":[]}", "score" : 6 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac42"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-fire\",\"route\":\"/popular\",\"class\":\"\",\"id\":\"\",\"text\":\"[[global:header.popular]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.popular]]\",\"enabled\":\"true\",\"properties\":{},\"order\":\"4\",\"groups\":[]}", "score" : 4 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac47"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-cogs\",\"route\":\"/admin\",\"class\":\"\",\"id\":\"\",\"text\":\"[[global:header.admin]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.admin]]\",\"groups\":[\"administrators\"],\"enabled\":\"true\",\"properties\":{},\"order\":\"7\"}", "score" : 7 }
    { "_id" : ObjectId("5f80a6737b2770d2a0a4ac3e"), "_key" : "navigation:enabled", "value" : "{\"iconClass\":\"fa-clock-o\",\"route\":\"/recent\",\"class\":\"\",\"id\":\"\",\"text\":\"[[global:header.recent]]\",\"textClass\":\"visible-xs-inline\",\"title\":\"[[global:header.recent]]\",\"enabled\":\"true\",\"properties\":{},\"order\":\"2\",\"groups\":[]}", "score" : 2 }
  • Indeed under Navigation in the ACP, I can see the routes are wrong:


    Note that all I have done since today morning is just install the awards plugin (which didn't work). I also tried to create a group and assign some members to a group which was also failing. some users would get into the group, some won't i.e even though the groups UI will show them as members, the user page won't show their badge or ownership.

    Sorry, I don't have anything concrete for you to fix yet. I am just writing things down as I find them.

  • Hi @girish . Sorry for my late reply. Yes, I was fixed in the same way you was. But this not fixes the issue. From time to time the issue comes again. I don't know why happens.

  • @normando Yes... we're still uncertain how this happens 🤔 We had an upgrade script to specifically fix this, but it shouldn't spontaneously revert back.

  • @julian today happens again. hahaha, very mistery thing

  • This was happening when you renamed groups. If you have groups that are owned by regular users whenever they renamed one of their groups it would cause this bug, same with admin page.

  • @baris wowww, thank you !!!!! I will wait for 1.15.x branch. Meanwhile I will observe groups renaming.

Suggested Topics