v1.14.2 Text area font bug (Russian language)

Technical Support

Suggested Topics

  • 0 Votes
    18 Posts

    @phenomlab said in How to change Font type? (serif vs. sans-serif):

    @crazycells they can only be used on websites if they are installed and included in the site you are viewing. This basically means that unless the font is available on he remote server, it won't display to other users if they do not have it installed (but would for you if you have it installed)

    This is why CSS on most websites will use system as a fallback so that the text is rendered even if the font cannot be found rather than the default of Times New Roman being displayed. System essentially uses whatever font is the default on the system viewing the website. In essence, under Windows, this would be SegoeUI. Under a Mac, it's of course different.

    Importing a font into your website isn't a difficult task. It's explained very well here

    How to import Google Web Font in CSS file?

    I'm working with a CMS which I only have access to the CSS file. So, I can't include anything in the <head> of the document. I was wondering if there was a way to import the web font from wit...


    Stack Overflow (stackoverflow.com)

    However, if you'd like to include a font that isn't from Google this is still possible, but the process differs slightly - and the caveat here is that not all fonts are created equal. Some do not lend themselves very well to rendering within web pages, and so it's always best to go for "web safe" versions. For example, just try "master of puppets" (yes, Metallica) and see what happens !

    In an seriousness, if you need help with fonts etc, happy to help.

    thank you very much, this was helpful! I will let you know about the progress 👍

  • 1 Votes
    6 Posts

    @volanar Yes! I like to think that for any particular problem, there are multiple viable solutions. Yours would definitely work as well 🙂

  • 0 Votes
    7 Posts


    No sorry, that didn't solve. But following worked:

    After importing mybb, upgrade it to v1.16.0 which produces "Error: ENOENT: no such file or directory, open '/nodebb/node_modules/nodebb-plugin-require/plugin.json' " as mentioned above. Back up both database and any image files imported from mybb under public/uploads/files Delete whole nodebb files and database Install original v1.16.0 (git clone -b v1.16.x https://github.com/NodeBB/NodeBB.git) Remove only the database, then restore database and image files using backups Works well, it doesn't produce any error even after installing quickstart plugin.

    Additionally, https://github.com/NodeBB/nodebb-plugin-quickstart doesn't work on v1.16.0.
    It shows following error on Chrome and the page got frozen while loading:
    colorpicker.js:11 Uncaught TypeError: n.ColorPicker is not a function
    at HTMLInputElement.<anonymous> (colorpicker.js:11)
    at Function.each (jquery.js:381)
    at C.fn.init.each (jquery.js:203)
    at Object.n.enable (colorpicker.js:8)
    at o (admin.js:31)
    at Object.i.init (admin.js:9)
    at ajaxify.js:336
    at Object.execCb (require.js:1696)
    at n.check (require.js:883)
    at n.<anonymous> (require.js:1139)

    Anyways, it's not to be discussed here I guess.
    Thank you very much!

  • Edit teaser text

    Technical Support
    0 Votes
    3 Posts

    There's two things i want to do.

    Shorten the teaser text Pull out a specific link to use as a button

    I think i figured it out though using something like { "hook": "filter:topics.get", "method": "teaserContentShort" }

    var Theme = { teaserContentShort: function (data, callback) { data.topics.forEach(topic => { topic.teaser.contentShort = topic.teaser.content.slice(0,20); }); callback(null, data); } };

    It seems to work. Hopefully thats not using the wrong paradigm.

  • Bug when saving sounds on ACP

    Unsolved Technical Support
    0 Votes
    4 Posts

    It removed error in console, but I got an error : Changes not saved
    And sounds are still not working