Problems updating nodebb



  • Following the instructions, I did:

    git fetch    # Grab the latest code from your current branch
    git checkout v0.4.3
    

    I was previously using 0.4.2. But when I try to git pull I get:

    git pull
    You are not currently on a branch, so I cannot use any
    'branch.<branchname>.merge' in your configuration file.
    Please specify which remote branch you want to use on the command
    line and try again (e.g. 'git pull <repository> <refspec>').
    See git-pull(1) for details.
    

    I'm not familiar with git and am unsure what to do. Thanks in advance!



  • OK I found the v0.4.x branch and did a pull on that instead:

    git pull
    Already up-to-date.
    

    The forum says 0.4.3 now in the Admin panel but I'm still getting the weird theme issue here.


  • Admin

    @Guiri said:

    git checkout v0.4.3

    Actually, you should check out the "x" branch, so git checkout v0.4.x :), though it seems like you figured that out!


  • Global Moderator

    Have you also run ./nodebb upgrade?



  • @a_5mith Yes, I did. Which I think I shouldn't have, because it's not a major version change?


  • Global Moderator

    @Guiri Yeah, you need to run upgrade after every pull request. Which you've done, which is good.

    So is it just the theme you're having issues with now?



  • @a_5mith Sorry, I suppose I sidetracked that other post. The theme issues were solved by rolling back the directory a few days using CrashPlan. However I'm still having issues. Somehow I ended up on master when I first installed. NodeBB is still v0.4.2 according to the Admin page.


  • Global Moderator

    @Guiri No problem, try this



  • Thank you again.

    git fetch
    remote: Counting objects: 57, done.
    remote: Compressing objects: 100% (55/55), done.
    remote: Total 57 (delta 15), reused 0 (delta 0)
    Unpacking objects: 100% (57/57), done.
    From git://github.com/designcreateplay/NodeBB
       29420d6..b1aae05  master     -> origin/master
    
    git checkout v0.4.x
    error: Untracked working tree file 'docs/modules/index.rst' would be overwritten by merge.
    
    # Okay, let's try to merge:
    git merge origin/v0.4.x
    Updating 8839780..7e1a072
    error: Untracked working tree file 'docs/modules/index.rst' would be overwritten by merge.  Aborting
    

    I think the problem is that somehow I'm still on master. Maybe I should just download 0.4.3 from the zip and move over the /public folder? I think that's Guiri-proof, right?


  • Global Moderator

    @Guiri NodeBB shouldn't be run from anywhere publicly accessible.

    Your error there would suggest a file exists remotely, but not locally. git will not allow you to overwrite a local untracked file.

    You may want to wait for either Julian or someone else with more git version knowledge, but I'm pretty sure that running git checkout -f master or git checkout -f v0.4.x would work, as it will force the files to be overwritten. But I've not used it, so I'd check with HQ. :)



  • Ah interesting. I put it in /var/www/ like my other web apps. Oops



  • Everything worked well using git checkout -f v0.4.x, including the git merge origin/v0.4.x. Trying to do the last step in the instructions:

    git pull
        You asked me to pull without telling me which branch you
        want to merge with, and 'branch.v0.4.x.merge' in
        your configuration file does not tell me, either. Please
        specify which branch you want to use on the command line and
        try again (e.g. 'git pull <repository> <refspec>').
        See git-pull(1) for details.
         
        If you often merge with the same branch, you may want to
        use something like the following in your configuration file:
         
            [branch "v0.4.x"]
            remote = <nickname>
            merge = <remote-ref>
         
            [remote "<nickname>"]
            url = <url>
            fetch = <refspec>
         
        See git-config(1) for details.
    

    EDIT: I solved this by associating it with v0.4.x git branch --set-upstream v0.4.x origin/v0.4.x and was able to 'git pull`!

    Now I'm having an upgrade error:

    ./nodebb upgrade
    npm WARN package.json express-namespace@0.1.1 No repository field.
    npm WARN package.json nodebb-plugin-dbsearch@0.0.9 No repository field.
    npm WARN package.json nodebb-plugin-imgur@0.0.14 No repository field.
    npm WARN package.json nodebb-plugin-rss@0.1.8 No repository field.
    npm WARN package.json reds@0.2.4 No repository field.
    npm WARN package.json express-namespace@0.1.1 No repository field.
    npm WARN package.json nodebb-plugin-dbsearch@0.0.9 No repository field.
    npm WARN package.json nodebb-plugin-imgur@0.0.14 No repository field.
    npm WARN package.json nodebb-plugin-rss@0.1.8 No repository field.
    npm WARN package.json reds@0.2.4 No repository field.
    info trying registry request attempt 1 at 22:18:37
    http GET https://registry.npmjs.org/nodebb-theme-vanilla
    info trying registry request attempt 1 at 22:18:37
    http GET https://registry.npmjs.org/nodebb-theme-lavender
    http 200 https://registry.npmjs.org/nodebb-theme-lavender
    npm http GET https://registry.npmjs.org/nodebb-theme-lavender/-/nodebb-theme-lavender-0.0.25-16.tgz
    npm http 200 https://registry.npmjs.org/nodebb-theme-lavender/-/nodebb-theme-lavender-0.0.25-16.tgz
    npm ERR! Error: shasum check failed for /root/tmp/npm-19468-s5Mk5pTq/1400210318188-0.42741939378902316/tmp.tgz
    npm ERR! Expected: 9819eed278a69ddd0af80c5f44965477b4cfc410
    npm ERR! Actual:   57a3e1badecdd876b68680a3f19554a9e74797ba
    npm ERR! From:     https://registry.npmjs.org/nodebb-theme-lavender/-/nodebb-theme-lavender-0.0.25-16.tgz
    npm ERR!     at /usr/lib/node_modules/npm/node_modules/sha/index.js:38:8
    npm ERR!     at ReadStream.<anonymous> (/usr/lib/node_modules/npm/node_modules/sha/index.js:85:7)
    npm ERR!     at ReadStream.EventEmitter.emit (events.js:117:20)
    npm ERR!     at _stream_readable.js:920:16
    npm ERR!     at process._tickCallback (node.js:415:13)
    npm ERR! If you need help, you may report this *entire* log,
    npm ERR! including the npm and node versions, at:
    npm ERR!     <http://github.com/npm/npm/issues>
    
    npm ERR! System Linux 2.6.32-431.11.2.el6.x86_64
    npm ERR! command "node" "/usr/bin/npm" "i" "nodebb-theme-vanilla" "nodebb-theme-lavender"
    npm ERR! cwd /var/www/nodebb
    npm ERR! node -v v0.10.26
    npm ERR! npm -v 1.4.10
    http 304 https://registry.npmjs.org/nodebb-theme-vanilla
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /var/www/nodebb/npm-debug.log
    npm ERR! not ok code 0
    info: NodeBB v0.4.3 Copyright (C) 2013-2014 DesignCreatePlay Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    info: 
    info: Beginning database schema update
    info: [2014/2/19] Updating MOTD to use the HTML widget - skipped
    info: [2014/2/20] Adding Recent Replies, Active Users, and Moderator widgets to category sidebar - skipped
    info: [2014/2/20] Adding Forum Stats Widget to the Homepage Footer - skipped
    info: [2014/2/20] Updating Lavender MOTD - skipped
    info: [2014/2/20] Activating NodeBB Essential Widgets - skipped
    info: [2014/2/22] Added categories to sorted set - skipped
    info: [2014/3/18] Migrating Markdown settings to new configuration - skipped
    info: [2014/3/21] Removing gids and pruning groups - skipped
    info: [2014/3/31] Re-adding copyright message into global footer widget - skipped
    info: [2014/4/1] Moved home sidebar widgets into draft zone - skipped
    info: [2014/4/2] Moved deprecated vanilla footer widgets into draft zone - skipped
    info: [upgrade] Schema already up to date!
    
    NodeBB Dependencies up-to-date!
    

    If I attempt to start nodebb after the failed upgrade, it leads to the theme problem which lead to my other post (at least I recreated the problem...).



  • I'm running into the exact same issue as yourself, is there an update on how this can be fixed?


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.