Using any sso plugin results in 404

Technical Support
  • So far in my forum I have installed nodebb-plugin-sso-google, nodebb-plugin-sso-twitter and nodebb-plugin-sso-steam.
    Whenever you click on any of them, you get redirected to a internal URL which gives you a 404.
    You can try it yourself.


    So far I have tried doing another clean install of v1.11.x (which is the one I installed on the original one) to no avail.
    Does anyone know how to solve this or what's going on?

  • I managed to debug what was going on and I discovered that NodeBB was doing everything correctly and that passport was working as it should, sending the right URL to redirect to, but my HTTP Reverse Proxy (In my case a IIS server) was somehow rewriting the Location header to use the servers domain.
    Managed to fix this by going into the Server settings, Application Request Routing and on the right going to the "Server Proxy Settings", and once there unchecking the "Reverse rewrite host in response headers" checkbox.

  • Hi,

    Sorry for my late reply, we had Christmas (Orthodox) these days. The thing is that I am not using IIS nor any other web server, but the standard server that comes with node.js on port 4567.

    I will go through this.

    if anyone else might have the slightest idea what could be the issue, you are welcomed to comment 🙂


  • @gorgiselkov The integrated Node.js web server? I believe you shouldn't do that, and as the guide states, you should always use a proxy server like, in my case IIS, but as the official guide states, Nginx.
    You should follow this guide in case you haven't (depending on your Servers OS):

  • Thanks, I will update you with details after configuring with a reverse proxy from nginx or iis 🙂

    Cheers and have a great day!

  • Hi again, did the proxying via nginx, same error. It looks like POST call to the callback url results in 404 error 😞 I checked the headers, looks ok.

  • @gorgiselkov What SSO are you trying to use?

    Also, try closing the nodebb app and starting it via "node app.js" and see what errors the console outputs, if any.

  • Hi,

    I am using this one:

    nodebb-plugin-sso-oauth (also tried this one nodebb-plugin-matr-forum-oauth2)

    There are no console errors whatsoever 😞


  • @gorgiselkov I believe that one might not be working because it's a skeleton plugin, and not an actual SSO auth (as stated on github page), unless you've configured it yourself but, it doesn't seem like it.

Suggested Topics

  • nodebb-plugin-imagemagick

    Solved Technical Support
    1 Votes
    3 Posts

  • 0 Votes
    3 Posts

  • 0 Votes
    5 Posts

  • 0 Votes
    3 Posts

  • 0 Votes
    1 Posts

| | | |