Cloudflare, ssl ...

Technical Support
  • Hello,

    I just try to create a new forum for a gaming community... I love nodebb and it is so fast and easy to configure... sadly I‘ve got problems with cloudflare and ssl... as soon as i activate the cloudflare clouds , my nodebb looses connection... i cant imagine that i need to change something in my conf or Nginx configuration? It‘s the same url, same port.. and also the ssl certificate doesn’t work which is free on cloudflare... do i need to change something in my config files or activate my ssl in the Nginx files? I found a cloudflare tutorial here in the forum but it seems to be outdated, because later in the answers everybody wrote something like cloudflare works now with sockets so there’s nothing to change in the config files ... hope somebody knows what I need to do...

Suggested Topics

  • Email test ssl error

    Solved Technical Support
    0 Votes
    2 Posts

    The error mysteriously disappeared and was replaced by an authentication error. I managed to have my Postmark account unlocked (btw, their support team was way much better than that of Sendgird, which still hasn't responded for 2 days since I requested till I am typing right now) and found that to use Postmark in Nodemailer you have to set the server api token as both the username and the password. This is quite counter intuitive, in my opinion.

    And I finally figured out that, the test email button works on your last saved settings, not what you are editing in the input boxes right now.

    So now Postmark is working. Thank God.

  • 0 Votes
    3 Posts

    @PitaJ Cool! If the query string only changes on ./nodebb build then "Cache everything" works well. I thought the query string was different for each user or represented some token/cookie. I guess I should have checked how it is generated before posting.

  • 1 Votes
    10 Posts

    I have the same problem, I host the NodeBB with IIS (IIS Node)

  • 0 Votes
    3 Posts

    Thank you for the suggestion! I didn't think about switching the subdomain do cloudflare-powered 😛

  • 1 Votes
    14 Posts

    Welp, I solved it.

    Turns out I had the wrong directory specified in nginx for static assets. It was pointing to a different install of nodebb. For some reason that caused issues with (and only with safari/opera for some reason).

    Now, here's the weird thing. I only recently started using nginx to serve the assets. Recently as in like this morning. Before that I simply had a proxy pass setup and let nodebb serve the assets. I'm not sure what was causing the 400/502 errors then but I'm just glad their solved now.