There was an error connecting to your database. Please try again.

Technical Support

Suggested Topics

  • topics.getTopic error

    Solved Technical Support
    0 Votes
    7 Posts

    @baris said in topics.getTopic error:


    This file needs to show the one you upload, it might be getting cached by nginx and nodebb, so try restarting both.

    yes, nginx restart solved the issue. Thanks 👍

  • 0 Votes
    1 Posts

    Since 1.16.2 (possibly before but no one mentioned it) We have been getting this desktop notifications popup for users on first registration:


    the desktop notifications plugin is showing as the latest version: 0.3.3 is anyone else seeing this issue?

  • Registration Error

    Technical Support
    0 Votes
    6 Posts

    Nevermind, the spam-be-gone plugin was causing it. Heres what i found in the console.

    at new ClientRequest (_http_client.js:52:11) at Object.exports.request (http.js:31:10) at Object.exports.request (https.js:199:15) at module.exports (/opt/nodebb/node_modules/simple-recaptcha-new/index.js:37:23) at Object.Plugin._recaptchaCheck (/opt/nodebb/node_modules/nodebb-plugin-spam-be-gone/library.js:282:3) at /opt/nodebb/node_modules/nodebb-plugin-spam-be-gone/library.js:211:11 at /opt/nodebb/node_modules/async/lib/async.js:718:13 at async.forEachOf.async.eachOf (/opt/nodebb/node_modules/async/lib/async.js:233:13) at _parallel (/opt/nodebb/node_modules/async/lib/async.js:717:9) at Object.async.parallel (/opt/nodebb/node_modules/async/lib/async.js:731:9) at Object.Plugin.checkRegister [as method] (/opt/nodebb/node_modules/nodebb-plugin-spam-be-gone/library.js:206:8) at /opt/nodebb/src/plugins/hooks.js:120:12 at /opt/nodebb/node_modules/async/lib/async.js:375:13 at iterate (/opt/nodebb/node_modules/async/lib/async.js:262:13) at Object.async.forEachOfSeries.async.eachOfSeries (/opt/nodebb/node_modules/async/lib/async.js:281:9) at Object.async.inject.async.foldl.async.reduce (/opt/nodebb/node_modules/async/lib/async.js:374:15) at fireFilterHook (/opt/nodebb/src/plugins/hooks.js:112:9) at Object.Plugins.fireHook (/opt/nodebb/src/plugins/hooks.js:93:4) at /opt/nodebb/src/controllers/authentication.js:76:12 at fn (/opt/nodebb/node_modules/async/lib/async.js:746:34) at /opt/nodebb/node_modules/async/lib/async.js:1213:16 at /opt/nodebb/node_modules/async/lib/async.js:166:37

    Seems like the recaptcha wasnt coded correctly. Or i didnt set it up correctly

  • 0 Votes
    15 Posts

    @JaredBusch said:

    A quick firewall-cmd --zone=public --add-port=4567/tcp --permanent and firewall-cmd --reload later
    And there we go.

    Thanks @rbeer for the information about nodejs versions. I did not see the indicator that you did obviously.

    Very nice! Glad to see it working now. 👍
    And, don't you worry! I was tearing my hair out for about an hour, when I stumbled upon that error some weeks ago. 🙂

  • Heroku Deploy Error

    Technical Support
    0 Votes
    5 Posts

    @markcarey did you get anywhere with this? Hitting the exact same problem