• @QWUX

    The proxy configuration is obviously not working. Post the entire config for the forums Nginx file here and see if you can find any messages from /var/log/nginx/error.log that you can post here.


  • @planner thanks for the quick reply...

    sites-available/www.talk.cloudmounta.in:

    server {
    listen 80;

    server_name talk.cloudmounta.in;
    
    location / {
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header Host $http_host;
        proxy_set_header X-NginX-Proxy true;
    
        proxy_pass http://127.0.0.1:4567/;
        proxy_redirect off;
    
        # Socket.IO Support
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
    }
    

    }

    the error log located where you asked is empty.
    and i believe i had made a symlink in sites-enabled in the nginx dir.


  • @QWUX

    No need for posting the contents of nginx.conf. You may edit the post and delete that part and enclose the entire contents of sites-available.talk.. inside the code block.

    I think the problem it's not working properly is that the proxy_pass value does not match the base_url value in config.json. Set proxy_pass http://talk.cloudmounta.in:4567; and see if that works. Don't forget to restart Nginx and NodeBB before testing.

  • GNU/Linux Admin

    @QWUX said:

    service nginx reload. it says fail.

    Can you paste the entire error message?


  • @ planner @julian thanks for all the help guys.
    this is where i have gotten - www.talk.cloudmounta.in:4567

    i updated the sites-available/www.talk.cloudmounta.in to have the proxy pass http://talk.cloudmounta.in:4567; - but www.talk.cloudmounta.in still just shows the nginx start page.

    now, for some reason, after i installed the Facebook sso plugin, i can not login normally, the login page only shows the alternate login (fb).

    i got the nginx service to restart, just fine thank you @julian

  • GNU/Linux Admin

    If only the alternate login shows up, then local logins were disabled -- do you remember doing this?


  • i didn't remember doing it, but i have got them back (by reverting to a snapshot of my droplet).

    so, at this stage, still don't have the nginx proxy/redirect working, and when users are logged in, the top bar doesn't have the conditional menu as shown on this forum, it just displays "register login" as though no user were logged in. but when in the admin section, my user avatar shows up there.


  • @QWUX

    This is not working and Nginx's error log is empty. There's obviously something that's misconfigured. Are you running anything in front of Nginx, like a cache server?


  • @planner - as far as i am aware, no. this is my first time doing this kind of thing though. i used the NODEBB for dummies install guide.

    haha its making me feel stupid.

    i am so thankful for all the help so far, this is by far one of the most active and helpful communities i have encountered.

    how would i find out if i am running a cache server? would it be easier i if created a login for one of you? i don't want to keep taking up your time if i keep breaking things, but i am dead certain that of all the forum software i have seen, i want to use NodeBB for sure.


  • @QWUX

    Well, how did you set up the original website before installing NodeBB? And just out of curiosity, did you install Nginx fresh with NodeBB or Nginx is the Web server that powered the site before you installed NodeBB?

Suggested Topics

  • 2
  • 15
  • 4
  • 18
  • 67
| |